<!-- html-header type=current begin -->
	
	<!DOCTYPE html>
	
	<html lang="en">
	<head>
	<!-- Render IE9 -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

	

<script>window.is_euro_union = 1;</script>
<script src="https://a.fsdn.com/con/js/sftheme/vendor/promise.polyfill.min.js"></script>
<script src="https://a.fsdn.com/con/js/sftheme/cmp.js"></script>
<script src="https://slashdot.org/country.js"></script>
<script type='text/javascript'>
if (window.is_euro_union) {
  bizx.cmp.init({
      // to test:   'Display UI': 'always',
      'Publisher Name': 'Slashdot',
      'Publisher Logo': 'https://a.fsdn.com/sd/sdlogo.svg',
      'Cookie Domain' : 'slashdot.org'
    });
}
</script>
<link rel="stylesheet" href="//a.fsdn.com/con/css/sftheme/sandiego/cmp.css" type="text/css">
<style type="text/css">
.qc-cmp-publisher-logo, .qc-cmp-nav-bar-publisher-logo {
    background-color: #016765;
}
</style>
<script>
if (!window.is_euro_union) {
(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '66');
}
</script>

	<script id="before-content" type="text/javascript">
(function () {
    if (typeof window.sdmedia !== 'object') {
         window.sdmedia = {};
    }
    if (typeof window.sdmedia.site !== 'object') {
        window.sdmedia.site = {};
    }

    var site = window.sdmedia.site;
    site.rootdir = "//slashdot.org";
}());

var pageload = {
	pagemark: '861298730153477412',
	before_content: (new Date).getTime()
};
function pageload_done( $, console, maybe ){
	pageload.after_readycode	= (new Date).getTime();
	pageload.content_ready_time	= pageload.content_ready - pageload.before_content;
	pageload.script_ready_time	= pageload.after_readycode - pageload.content_ready;
	pageload.ready_time		= pageload.after_readycode - pageload.before_content;
	// Only report 1% of cases.
	maybe || (Math.random()>0.01) || $.ajax({ data: {
		op: 'page_profile',
		pagemark: pageload.pagemark,
		dom: pageload.content_ready_time,
		js: pageload.script_ready_time
	} });
}
</script>
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"> 
	
		<title>Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable - Slashdot</title>
		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
	  
		<meta name="description" content="Monday Red Hat and IBM jointly filed their own amicus brief with the U.S. Supreme Court in the &#34;Google vs. Oracle&#34; case, arguing that APIs cannot be copyrighted. 

&#34;That simple, yet powerful principle has been a cornerstone of technological and economic growth for over sixty years. When published (a...">
	    
		<meta name="twitter:card" content="summary">
		<meta name="twitter:site" content="@slashdot">
		<meta name="twitter:domain" content="linux.slashdot.org">
		<meta property="og:url" content="https://linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable">
	    
		<meta property="og:title" content="Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable - Slashdot">
		<meta property="og:description" content="Monday Red Hat and IBM jointly filed their own amicus brief with the U.S. Supreme Court in the &#34;Google vs. Oracle&#34; case, arguing that APIs cannot be copyrighted. 

&#34;That simple, yet powerful principle has been a cornerstone of technological and economic growth for over sixty years. When published (a...">
	  
	
	
		<meta property="og:image" content="https://a.fsdn.com/sd/topics/topicgoogle_fb.gif">
	
		<meta property="fb:admins" content="100000696822412">
		<meta property="fb:page_id" content="267995220856">
	
		<meta name="viewport" content="width=1000, user-scalable=yes, minimum-scale=0, maximum-scale=10.0" />
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="apple-mobile-web-app-status-bar-style" content="black">
	
		<link rel="canonical" href="https://linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable">
		
		<link rel="alternate" media="only screen and (max-width: 640px)" href="http://m.slashdot.org/story/366050" >
	

		<link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/classic.ssl.css?4f1bc126f9ccc5b3" >
		<!--[if IE 8]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie8-classic.ssl.css?4f1bc126f9ccc5b3" ><![endif]-->
		<!--[if IE 7]><link rel="stylesheet" type="text/css" media="screen, projection" href="//a.fsdn.com/sd/ie7-classic.ssl.css?4f1bc126f9ccc5b3" ><![endif]-->
	
	
	



	
	<!--  -->

	
	

	
	<!-- SMACKS: NEW CSS -->
	<link rel="stylesheet" href="//a.fsdn.com/sd/css/app.css?4f1bc126f9ccc5b3">

	<script type='text/javascript'>
var _gaq = _gaq || [];
</script>





         
   
   

<script type="text/javascript" id="pbjs_script" data-dom="https://d3tglifpd8whs6.cloudfront.net"  src="https://d3tglifpd8whs6.cloudfront.net/js/prebid/slash-story/slash-story.min.js"></script>
<script type='text/javascript'>
    /*global performance */
    var googletag = window.googletag || {};
    googletag.cmd = googletag.cmd || [];

    	window.SD = {};
		window.SD.Ads = {};

		window.SD.Ads.slotsById = {};
		window.SD.Ads.idsByPath = {};

		window.SD.Ads.visibleTime = {};
		window.SD.Ads.Helpers = {};

		//window.SD = SD;


window.Ads_disallowPersonalization = 1;
    bizx.cmp.ifConsent('all', 'all', function(){
        window.Ads_disallowPersonalization = 0;
      }, function(){
        window.Ads_disallowPersonalization = 1;
      }, function () {
        window.bizxPrebid.Ads.initPrebid(window.bizxPrebid.adUnits);
      });
</script>

<!-- prep GPT ads -->
<script type='text/javascript'>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</script>



<!-- CrossPixel -->
<script type="text/javascript"> try{(function(){ var cb = new Date().getTime(); var s = document.createElement("script"); s.defer = true; s.src = "//tag.crsspxl.com/s1.js?d=2397&cb="+cb; var s0 = document.getElementsByTagName('script')[0]; s0.parentNode.insertBefore(s, s0); })();}catch(e){} </script>

<!-- AdBlock Check -->
<script>
var isAdBlockActive = true;
</script>
<script async src="//a.fsdn.com/sd/js/scripts/ad.js?4f1bc126f9ccc5b3"></script>
<!-- Ad-Refresh code -->
<script>


window.SD.Ads.visibilityChangedTracker = function(event) {
	var id = event.slot.getSlotElementId();
	if (!window.SD.Ads.visibleTime.hasOwnProperty(id)) {
		window.SD.Ads.visibleTime[id] = {
			visible: false,
			prevVisibleTotal: 0,
			wasVisibleBeforePageBgd: false,
			reloadCount: 0
		};
	}
	var timeinfo = window.SD.Ads.visibleTime[id];
	if (event.inViewPercentage >= 50 && !document.hidden) {
		if (!timeinfo.visible) {
			timeinfo.visible = performance.now();
		}
	} else {
		if (timeinfo.visible) {
			timeinfo.prevVisibleTotal += performance.now() - timeinfo.visible;
			timeinfo.visible = false;
		}
	}
};

window.SD.Ads.setupAdRefresh = function() {
	document.addEventListener('visibilitychange', function () {
		for (var id in window.SD.Ads.visibleTime) {
			if (window.SD.Ads.visibleTime.hasOwnProperty(id)) {
				var timeinfo = window.SD.Ads.visibleTime[id];
				if (document.hidden) {
					timeinfo.wasVisibleBeforePageBgd = !!timeinfo.visible;
					if (timeinfo.visible) {
						timeinfo.prevVisibleTotal += performance.now() - timeinfo.visible;
						timeinfo.visible = false;
					}
				} else if (!document.hidden && timeinfo.wasVisibleBeforePageBgd) {
					timeinfo.visible = performance.now();
				}
			}
		}
	}, false);

	// after 30 sec, start checking every second for reload
	var LIMIT_MS = 30000;
	setTimeout(function () {
		//
		setInterval(function () {
			if (document.hidden) {
				return;
			}
			for (var id in window.SD.Ads.visibleTime) {
				if (window.SD.Ads.visibleTime.hasOwnProperty(id)) {
					var timeinfo = window.SD.Ads.visibleTime[id];
					if (timeinfo.visible &&
						timeinfo.prevVisibleTotal + (performance.now() - timeinfo.visible) >= LIMIT_MS &&
						timeinfo.reloadCount < 50
					) {
						timeinfo.reloadCount++;
						timeinfo.visible = false;
						timeinfo.prevVisibleTotal = 0;
						window.SD.Ads.Helpers.refreshBids([id]);
					}
				}
			}
		}, 1000);
	}, LIMIT_MS);
};

window.SD.Ads.Helpers.refreshBids = function (reloadIds) {
		console.log('AD REFRESH: refreshBids', reloadIds);
		pbjs.que.push(function () {
			for (var i = reloadIds.length-1; i >= 0; i--) {
				var id = reloadIds[i];
				// clear out winner status from earlier auctions
				if (bizxPrebid.Ads.prebidWinners[id]) {
					delete bizxPrebid.Ads.prebidWinners[id];
				}
				// if has complement (hubicon), remove it since they are just house ads and can cause funky layouts if this leaderboard is refreshed to a different size
				var path = window.SD.Ads.slotsById[id].getAdUnitPath();
				/*var complement = gptadComplements[path];
				if (complement) {
					var complement_shortname = complement[0];
					var complement_path = "/41014381/SD/" + complement_shortname;
					var slot = window.SD.Ads.slotsById[window.SD.Ads.idsByPath[complement_path]];
					if (slot) {
						googletag.destroySlots([slot]);
						var $wrappedAd = $(window.SD.Ads.Helpers.getContainerIDFromPath(complement_path));
						$wrappedAd.remove();
						delete gptadComplements[path];
					}
				}*/

			}

			pbjs.requestBids({
				timeout: window.bizxPrebid.PREBID_TIMEOUT,
				adUnitCodes: reloadIds,
				bidsBackHandler: function () {
					var reloadSlots = reloadIds.map(function(id) { return window.SD.Ads.slotsById[id]; });

					// clear out previous sizing attrs, as they may change after refresh
/*
					for (var i = 0; i < reloadSlots.length; i++) {
						var $wrappedAd = $(window.SD.Ads.Helpers.getContainerIDFromPath(reloadSlots[i].getAdUnitPath()));
						var classes = $wrappedAd.attr('class').split(' ');
						for (var j = 0; j < classes.length; j++) {
							if (classes[j].indexOf('sz_') >= 0) {
								$wrappedAd.removeClass(classes[j]);
							}
						}
					}
*/
					pbjs.setTargetingForGPTAsync(reloadIds);
					googletag.pubads().refresh(reloadSlots);
				}
			});
		});
	}
</script>
</head>
<body class="anon firehose ">

	
	<script src="//a.fsdn.com/sd/all-minified.js?4f1bc126f9ccc5b3" type="text/javascript"></script>
	
	
	<script type="text/javascript">
(function(){
var regexp=/\s*(?:\d+|many)\s+more\s*/i;

	
	var auto_more_count = 1;

	function auto_more(){
		var $more_link = $('#more-experiment a');
		$more_link.each(function(){
			var $lastitem = $('#firehoselist>article.fhitem:visible:last');
			if ( Bounds.intersect(window, $lastitem) ) {
			
			
				!--auto_more_count && (auto_more=undefined);
				// don't allow a call till the next paginate gets built and |more_possible|
				$(document).unbind('scroll', call_auto_more);
			}
		});
	};

	function call_auto_more(){ auto_more && auto_more(); }
	

$('#more-experiment a').
	live('more-possible', function( event ){
		var $more_link=$(this);
		if ( regexp.test($more_link.text()) ) {
		
			$(document).bind('scroll', call_auto_more);
		} else {
			$(document).unbind('scroll', call_auto_more);
		
		}
	});
})();
</script>
	<!--[if lt IE 9]><script src="//a.fsdn.com/sd/html5.js"></script><![endif]-->
	
	
	<script type="text/javascript">
		(function() {
			if (typeof window.janrain !== 'object') window.janrain = {};
			if (typeof window.janrain.settings !== 'object') window.janrain.settings = {};

			/* _______________ can edit below this line _______________ */

			janrain.settings.tokenUrl = 'https://slashdot.org/token_callback.pl';
			janrain.settings.type = 'embed';
			janrain.settings.appId = 'ggidemlconlmjciiohla';
			janrain.settings.appUrl = 'https://login.slashdot.org';
			janrain.settings.providers = [
			    'googleplus',
			    'facebook',
			    'twitter',
			    'linkedin'];
			janrain.settings.providersPerPage = '5';
			janrain.settings.format = 'one column';
			janrain.settings.actionText = 'Sign in with';
			janrain.settings.showAttribution = false;
			janrain.settings.fontColor = '#666666';
			janrain.settings.fontFamily = 'lucida grande, Helvetica, Verdana, sans-serif';
			janrain.settings.backgroundColor = '#ffffff';
			janrain.settings.width = '300';
			janrain.settings.borderColor = '#cccccc';
			janrain.settings.borderRadius = '5';    janrain.settings.buttonBorderColor = '#CCCCCC';
			janrain.settings.buttonBorderRadius = '0';
			janrain.settings.buttonBackgroundStyle = 'gray';
			janrain.settings.language = '';
			janrain.settings.linkClass = 'janrainEngage';

			/* _______________ can edit above this line _______________ */

			function isReady() { janrain.ready = true; };
			if (document.addEventListener) {
			  document.addEventListener("DOMContentLoaded", isReady, false);
			} else {
			  window.attachEvent('onload', isReady);
			}

			var e = document.createElement('script');
			e.type = 'text/javascript';
			e.id = 'janrainAuthWidget';

			e.src = 'https://rpxnow.com/js/lib/login.slashdot.org/engage.js';

			var s = document.getElementsByTagName('script')[0];
			s.parentNode.insertBefore(e, s);
		})();
	</script>
	
		<script src="//cdn-social.janrain.com/social/janrain-social.min.js"></script>
		<script type="text/javascript">
			(function($) {
				$(function(){
					janrain.settings.appUrl = "https://login.slashdot.org";
					$twitter = $('body .janrain_twitterButton');
					$twitter.append('<i class="icon-twitter"></i>');

					janrain.settings.social = {
						providers: [
							"native-facebook",
							"twitter",
							"linkedin",
							"native-reddit"
						],
						shareCountMin: "100",
						shareCountMode: "combined"
					};
				});
			})($j);
		</script>
	<!-- index2_variant ||-->
	
	<!-- TABOOLA -->
	<script type="text/javascript">
	if (!window.is_euro_union) {
	  window._taboola = window._taboola || [];
	  _taboola.push({home:'auto'});
	  !function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/slashdot/loader.js');
	}
	</script>
	
	<!-- html-header type=current end --><!-- header type=current begin -->
	
	
	
	<link rel="top"       title="News for nerds, stuff that matters" href="//slashdot.org/" >
<link rel="search"    title="Search Slashdot" href="//linux.slashdot.org/search.pl">
<link rel="alternate" title="Slashdot RSS" href="http://rss.slashdot.org/Slashdot/slashdotLinux" type="application/rss+xml">
	<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">

	
		<div id="top_parent"></div>
		<a name="topothepage"></a>
		
		<div class="container">
			<div class="nav-wrap">
				<nav class="nav-primary" role="navigation" aria-label="Global Navigation">
					<h1 class="logo">
	<a href="//slashdot.org"><span>Slashdot</span></a>
</h1>

<ul class="nav-site">
	<li><a href="//slashdot.org"><i class="icon-book" title="Stories"></i><span>Stories</span></a></li>
	<li>
		<ul class="filter-firehose">
			<li class="nav-label">Firehose <i class="icon-angle-right"></i></li>
			<li><a href="//slashdot.org/recent">All</a></li>
			<li><a href="//slashdot.org/popular">Popular</a></li>
		</ul>
	</li>
	<li><a href="//slashdot.org/polls"><i class="icon-chart-bar" title="Polls"></i><span>Polls</span></a></li>

	<!--
	<li><a href="//ask.slashdot.org"><i class="icon-question-circle"></i><span>Ask</span></a></li>
	
	<li><a href="//events.slashdot.org"><i class="icon-calendar"></i><span>Events</span></a></li>
	-->
	<li><a href="http://deals.slashdot.org/?utm_source=slashdot&amp;utm_medium=navbar&amp;utm_campaign=dealshp_1" target="_blank"><i class="sd-mini" title="Deals"></i> <span>Deals</span></a></li>
</ul>
<a href="//slashdot.org/submission" class="btn btn-success">Submit</a>
				</nav>
				<nav class="nav-user" role="navigation" aria-label="user access and account controls">
					<form id="search" class="form-inline nav-search-form" method="get" action="//slashdot.org/index2.pl">
<!-- //linux.slashdot.org/index2.pl" -->
	<div class="form-group">
		<label class="sr-only" for="sitesearch">Search Slashdot</label>
		<div class="input-group">
			<input type="text" id="" class="" name="fhfilter" value="" placeholder="Search">
		</div>
	</div>
	<button type="submit" class="btn icon-search"></button>
</form>
<ul class="user-access">
	
		
			<li >
				<a href="//slashdot.org/my/login"  onclick="show_login_box(); return false;"><i class="icon-login"></i><span> Login</span></a>
				
			</li>
		
	
		
			<li class="nav-label">or</li>
		
	
		
			<li >
				<a href="//slashdot.org/my/newuser"  ><i class="icon-user-add"></i><span> Sign up</span></a>
				
			</li>
		
	
</ul>
				</nav>
			</div>
			<div class="nav-secondary-wrap">
				<nav class="nav-secondary" role="secondary-navigation">
	<ul>
		<li class="nav-label">Topics: </li>
		<li><a href="//devices.slashdot.org">Devices</a></li>
		<li><a href="//build.slashdot.org">Build</a></li>
		<li><a href="//entertainment.slashdot.org">Entertainment</a></li>
		<li><a href="//technology.slashdot.org">Technology</a></li>
		<li><a href="//slashdot.org/?fhfilter=opensource">Open Source</a></li>
		<li><a href="//science.slashdot.org">Science</a></li>
		<li><a href="//yro.slashdot.org">YRO</a></li>
		<!-- <li><a href="//slashdot.org/topics.pl">more...</a></li> -->
	</ul>
</nav>
<nav class="nav-social" role="social navigation">
	<ul>
		<li class="nav-label">Follow us:</li>
		<li><a href="http://rss.slashdot.org/Slashdot/slashdotMain" target="_blank" rel="nofollow"><i class="icon-rss-squared"></i><span class="sr-only">RSS</span></a></li>
		<li><a href="http://www.facebook.com/slashdot" target="_blank" rel="nofollow"><i class="icon-facebook-squared"></i><span class="sr-only">Facebook</span></a></li>
		<li><a href="https://www.linkedin.com/company/slashdot" target="_blank" rel="nofollow"><i class="icon-linkedin-squared"></i><span class="sr-only">Google+</span></a></li>
		<li><a href="http://twitter.com/slashdot" target="_blank" rel="nofollow"><i class="icon-twitter-squared"></i><span class="sr-only">Twitter</span></a></li>
		<li><a href="//slashdot.org/newsletter" target="_blank" rel="nofollow"><i class="icon-mail-squared"></i><span class="sr-only">Newsletter</span></a></li>
	</ul>
</nav>
			</div>
		</div>

		<section>
		
			<div class="message-bar" id="firehose-message-tray">
				<span class="icon-quote-left"></span>
				<p>
					
						
						Please <strong><a href="//linux.slashdot.org/login.pl">create an account</a></strong> to participate in the Slashdot moderation system
					
				</p>
			</div>
		
		
			<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		
		
			<div class="banner-wrapper">
				<div class="adwrap adwrap-unviewed banner-contain">
					
					<div id='div-gpt-ad-728x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_a');});</script></div>
					<div id='div-gpt-ad-hubicon_200x90_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-hubicon_200x90_a');});</script></div>
				</div>
			</div>
		
		<a name="main-articles"></a>
	
	<!-- header type=current end --><!-- body begin -->







	

	<style type="text/css">
menu, menu * {
	text-decoration:none;
}

menu[type=context] {
	display:none;
	position:absolute;
	z-index:10000;
}

menu[type=context]:not(.brief) {
	background-color:#dfdfdf;
	margin:0;
	padding:2px 0.5em;
	border-style:solid;
	border-width:1px;
	border-color:#eeeeee #aaaaaa #aaaaaa #eeeeee;
	-moz-border-radius-topright:.7em;
	-webkit-border-top-right-radius: 0.7em 0.7em;
}

menu.full[type=context] > a.slash-hover:first-child {
	-moz-border-radius-topright:.6em;
	-webkit-border-top-right-radius: 0.6em 0.6em;
}



menu.brief[type=context] > a {
	-moz-border-radius:.6em;
	-webkit-border-radius: 0.6em;
	color:#ffffff;
	background-color:#000000;
}

/*
span.briefmenu a.tag:not(.datatype) {
    padding-left:.5em;
}
*/




/* #tag-menu a, #feedback-menu a  { */
menu.tag-menu-admin a {
	display:list-item;
	list-style:none;
	text-align:left;
	font-weight:bold;
	color:black;
	padding:0.1em 0.5em;
	margin:-0.1em -0.5em;
	cursor:pointer;
}


.tags .edit-bar { position:relative; }
article aside .share .addthis_toolbox { display:block; width:60px; float:left; }
article aside.view_mode .share { min-width:120px; padding-top:.5em; }
#firehose.list article header h2 {padding-left: 20px; !important}
.novote .vote { display:none; }

.vote > a, .votedup > a, .voteddown > a {
	display:inline-block;
	height:22px;
	width:22px;
	margin: 2px 10px 0 0;
	color:rgb(255,255,255);
	text-decoration:none;
	line-height:22px;
	text-align:center;
	font-weight:bold;
	font-size:14px;
	border-width:1px;
	border-style:solid;
	border-color:rgba(0,0,0,0.5);
}

.vote > a, .votedup > a, .voteddown > a {color:rgb(0,0,0);}

article.fhitem-submission h2 .vote > a, article.fhitem-submission h2 .votedup > a, article.fhitem-submission h2 .voteddown > a { border-color:rgba(0,0,0,0.15); }
.vote .up, .vote .down, .votedup .up, .votedup .down, .voteddown .up, .voteddown .down { border-radius: 4px; -moz-border-radius: 4px; -webkit-border-radius: 4px; /* text-shadow:0 0 2px #000000; }*/}
article:not(.fhitem-story) .vote .up,article:not(.fhitem-story) .vote .down,article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .votedup .down,article:not(.fhitem-story) .voteddown .up,article:not(.fhitem-story) .voteddown .down { /*text-shadow:none !important; */}
.voteddown .down, .votedup .up { margin-right: 10px; text-indent:2px; line-height:24px; }
article:not(.fhitem-story) .votedup .up,article:not(.fhitem-story) .voteddown .down {background: rgb(174,174,174);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(174,174,174)), to(rgb(193,193,193)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(193,193,193), rgb(174,174,174) 100%);color:rgb(0,0,0);}
article.fhitem-story .votedup .up,article.fhitem-story .voteddown .down {background: rgb(0,66,66);background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(0,53,53)), to(rgb(0,102,102)));background-image: -moz-linear-gradient(100% 100% 90deg,rgb(0,102,102), rgb(0,53,53) 100%);}




#tag-menu span.var-tag {
font-weight:normal;
color:#444444;
}

menu.reasons-menu a {
padding:0 .25em 0 .25em;
font-size:80%;
-moz-border-radius:.5em;
-webkit-border-radius:.5em;
cursor:pointer;
}

menu.reasons-menu a:hover {
background:rgb(153,153,153);
background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102);
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102)));
color:#fff;
text-decoration:none;
font-weignt:normal;
}

article.fhitem-story menu.reasons-menu a:hover {
background:#002323 !important;
background:-moz-linear-gradient(100% 100% 90deg, #002323, #005353 70%) repeat scroll 0 0 #002323 !important;
background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(#005353), to(#002323)) !important;
}


menu.reasons-menu {
	display:none;
	margin:0;
	padding:0;
}

div.fhitem h3 menu.reasons-menu {
margin:0.25em 0 0;
}

div.fhitem h3 menu.reasons-menu a.tag {
font-size:.8em;
}

#tag-menu a.slash-hover,
#feedback-menu a.slash-hover,

.tag-display span.tag:hover,
.tag-display span.tag.trigger {
	color:white;
	background-color:rgb(0, 85, 85);
}

#tag-menu a.slash-hover span.var-tag {
	color:#eee;
}

.tag-entry.default {
        color:#ccc;
}

.brief .nix {
	margin-top:-1.35em;
	margin-left:0px;
	margin-top:-1.15em;
	text-decoration:none;
	line-height:1.35em;
	padding:0 2px;
	-moz-border-radius:.6em 0 0 .6em;
	-webkit-border-radius:.6em 0 0 .6em;
	-o-border-radius:.6em 0 0 .6em;
	border-radius:.6em 0 0 .6em;
    color:#fff !important;
    background:transparent !important;
}

.brief .nix:hover {
    background:rgb(153,153,153) !important;
    background:-moz-linear-gradient(100% 100% 90deg, rgb(102,102,102), rgb(153,153,153) 70%) repeat scroll 0 0 rgb(102,102,102) !important;
    background-image: -webkit-gradient(linear, 0% 0%, 0% 100%, from(rgb(153,153,153)), to(rgb(102,102,102))) !important;
}

</style>

<menu id="nix-reasons" style="display:none">
	<a class="tag">binspam</a><a class="tag">dupe</a><a class="tag">notthebest</a><a class="tag">offtopic</a><a class="tag">slownewsday</a><a class="tag">stale</a><a class="tag">stupid</a>
</menu>
<menu id="nod-reasons" style="display:none">
	<a class="tag">fresh</a><a class="tag">funny</a><a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">maybe</a>
</menu>
<menu id="comment-nix-reasons" style="display:none">
	<a class="tag">offtopic</a><a class="tag">flamebait</a><a class="tag">troll</a><a class="tag">redundant</a><a class="tag">overrated</a>
</menu>
<menu id="comment-nod-reasons" style="display:none">
	<a class="tag">insightful</a><a class="tag">interesting</a><a class="tag">informative</a><a class="tag">funny</a><a class="tag">underrated</a>
</menu>

<menu id="tag-nod-reasons" style="display:none">
	<a class="tag">descriptive</a>
</menu>
<menu id="feedback-menu" class="tag-menu-admin" type="context">
	<a class="tag">typo</a><a class="tag">dupe</a><a class="tag">error</a>
</menu>
<menu id="tag-menu" class="tag-menu-admin none" type="context">

<!--	<a data-op="!" class="nix">!<span class="var-tag hide"></span></a>-->

</menu>

<script type="text/javascript">
$(function(){
var $CURRENT_MENU, $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/, IE7=/^7\.0/, TAG_PREFIX=/^\/tag\//;

function get_tag_name( $tag ){
	return ($tag.attr('href') || '').replace(TAG_PREFIX, '') || $tag.text().toLowerCase();
}

function trigger_menu( e, selector, $menu, menu_content ){
	var $target=$(original_target(e, selector)), in_use=$target.is('.trigger');
	if ( $CURRENT_MENU ) {
		$CURRENT_MENU.menu('cancel', e);
		$CURRENT_MENU = null;
	}

	if ( !in_use ) {
		menu_content && $menu.stop(true, true).hide().html(menu_content);
		($CURRENT_MENU=$menu).menu('context', e);
	}
	return !in_use;
}

function open_menu( trigger, $menu ){
	var $trigger=$(trigger), $fhitem=$trigger.closest('.fhitem');
	$fhitem.length && user_intent('interest', $fhitem[0]);

	$menu.appendTo(document.body).css({ opacity:0 }).show();

	var 	right	= $fhitem.offset().left + $fhitem.width(),
		global	= $trigger.offset(),
		local	= $menu.offsetParent().offset();

	// Ugly IE position hack required:
	$.browser.msie && IE7.test($.browser.version) && (local.top = 0);

	// pin the menu (horizontally) on-screen
	global.left = Math.min(global.left, right-$menu.width());

	$trigger.addClass('trigger');
	$menu.css({
		position:	'absolute',
		top:		global.top - local.top + $trigger.height(),
		left:		global.left - local.left,
		opacity:	1
	});
}

function close_menu( trigger, $menu ){
	$menu.hide();
	$(trigger).removeClass('trigger');
	($CURRENT_MENU===$menu) && ($CURRENT_MENU=false);
}

/* T2 tag context-menu */
var $TAG_MENU=$('#tag-menu'), NOTNOT=/^!!/;


    var user_is_admin = 0;



$('a[rel=tag]').live('mousedown',function(ea){
    window.open(this.href);
    return false;
})

$('.tag-bar .disagree').live('mousedown',function(ee){
	var fhitem = $(original_target(ee)).closest('.fhitem')[0],
		command = ('!' + $(original_target(ee)).attr("data-tag")).replace(NOTNOT, '');
    try { Tags.submit(fhitem, command); } catch ( err ) {  }
    return false;
})



$('a[rel=tag]').
	live('mousedown', function( e ){
        
            return true;
        

	}).
	live('click', function( e ){
		if ( !logged_in ) {
			var	target	= original_target(e),
				tag	= $(target).text();
			addfhfilter(tag);
		}
		e.preventDefault();
		return false;
	});

$TAG_MENU.menu({
	cssNamespace: 'slash',
	liveTriggers: true,
	clickDuration: 300,

	start: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			context	= firehose_settings && firehose_settings.viewtitle;

		// Insert the tagname into the menu items where needed.
		$TAG_MENU.find('span.var-tag').text(tag);
		$TAG_MENU.find('a.nix').attr('title','not ' + tag);


			// non-admins may only delete their own tags
		$TAG_MENU.find('a:[data-op="-"]').toggle($tag.is('.my'));
	

		// *tagname* in *viewtitle*
		$TAG_MENU.find('a:[data-op="="]').toggle(!!context);
		context && $TAG_MENU.find('span.var-view').text(context);

		open_menu($tag, $TAG_MENU);
	},

	select: function( e, ui ){
		var	$tag	= $(ui.trigger),
			tag	= get_tag_name($tag),
			op	= $(ui.select).attr('data-op'),
			fhitem,
			command;

		// Global for positioning other things.
		$related_trigger = $tag;

		switch ( op ) {
			case '=':
				addfhfilter(tag);
				break;

			default:
				fhitem = $tag.closest('.fhitem')[0];
				command = (op + tag).replace(NOTNOT, '');
				try { Tags.submit(fhitem, command); } catch ( err ) {  }
				break;
		}
	},

	stop: function( e, ui ){ close_menu(ui.trigger, $TAG_MENU); }
});




/* T2 feedback context-menu */



/* T2 datatype context-menu (admin-only) */






});
</script>

	

<!-- SMACKS: BEGIN STORY CONTENT -->
<div class="container">
	<!--SMACKS: BEGING CENTER COLUMN -->
	<div class="main-wrap has-rail-right">
		<div class="main-content">
			<div class="grid_24 a2 ">
			</div>
			<div id="firehose" class="nothumbs">
			<div id="firehoselist" class="fhroot fleft  grid_24">
				<div id="announcement">
  <div id="announcementText" style="display: none;"> <span class="headline">Check out Slashdot on <a href="https://www.linkedin.com/company/slashdot" rel="nofollow">LinkedIn</a> & <a href="https://www.minds.com/slashdot?referrer=slashdot" rel="nofollow">Minds!</a> | Migrate from GitHub to SourceForge quickly and easily with <strong><a href="https://sourceforge.net/p/forge/documentation/GitHub%20Importer/" rel="nofollow">this tool</a></strong>.</span> Check out all of SourceForge&rsquo;s <strong><a href="https://sourceforge.net/blog/brief-history-sourceforge-look-to-future/" rel="nofollow">improvements.</a></strong></div>
  <a href="" class="btn-close" title="don't show me this again" onclick="closeAnnouncement(); return false;">&times;</a>
</div>


<script type="text/javascript">

if (!$.cookie('hide_sitenotice_36')) {
	$('#announcement').fadeIn(300);
}

function closeAnnouncement() {
	$('#announcement').fadeOut(300);
	$.cookie('hide_sitenotice_36', 'true', { path: '/', domain: 'slashdot.org', expires: 1 });
}
</script>
				<article id="firehose-123593424" data-fhid="123593424" data-fhtype="story" class="fhitem fhitem-story article usermode thumbs grid_24">
		<span class="sd-info-block" style="display: none">
			<span class="sd-key-firehose-id">123593424</span>
			<span class="type">story</span>
			
		</span>







	
	

<header>
	
		<span class="topic" id="topic-123593424">
			<a href="//linux.slashdot.org/index2.pl?fhfilter=google" onclick="return addfhfilter('google');">
			
				<img src="//a.fsdn.com/sd/topics/google_64.png" width="64" height="64" alt="Google" title="Google">
			
		</a>
		
	
		
		
		
		

		
		<a href="//linux.slashdot.org/index2.pl?fhfilter=oracle" onclick="return addfhfilter('oracle');">
			
				<img src="//a.fsdn.com/sd/topics/oracle_64.png" width="64" height="64" alt="Oracle" title="Oracle">
			
		</a>
		
	
		
		

		
		<a href="//linux.slashdot.org/index2.pl?fhfilter=redhat" onclick="return addfhfilter('redhat');">
			
				<img src="//a.fsdn.com/sd/topics/redhat_64.png" width="64" height="64" alt="Red Hat Software" title="Red Hat Software">
			
		</a>
		
	
		
		

		
		<a href="//linux.slashdot.org/index2.pl?fhfilter=ibm" onclick="return addfhfilter('ibm');">
			
				<img src="//a.fsdn.com/sd/topics/ibm_64.png" width="64" height="64" alt="IBM" title="IBM">
			
		</a>
		
	
		
		

		
		<a href="//linux.slashdot.org/index2.pl?fhfilter=opensource" onclick="return addfhfilter('opensource');">
			
				<img src="//a.fsdn.com/sd/topics/opensource_64.png" width="64" height="64" alt="Open Source" title="Open Source">
			
		</a>
		
	
		
		

		
		<a href="//linux.slashdot.org/index2.pl?fhfilter=court" onclick="return addfhfilter('court');">
			
				<img src="//a.fsdn.com/sd/topics/court_64.png" width="64" height="64" alt="The Courts" title="The Courts">
			
		</a>
		</span>
	

	<h2 class="story">
		

		

		
		

		

		

		

		<span id="title-123593424" class="story-title"> <a   href="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable">Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable</a> <span class=" no extlnk"><a class="story-sourcelnk" href="https://www.redhat.com/en/blog/red-hat-urges-us-supreme-court-support-unrestricted-use-software-interfaces"  title="External link - https://www.redhat.com/en/blog/red-hat-urges-us-supreme-court-support-unrestricted-use-software-interfaces" target="_blank"> (redhat.com) </a></span></span>

		
		
		<!--<span class="comments commentcnt-123593424" >41</span>-->
		

		
		<!-- comment bubble -->
		
			<span class="comment-bubble"><a href="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable#comments" title="">41</a></span>
		
	</h2>
	<div class="details" id="details-123593424">
		<span class="story-details">
		<span class="story-views">
			<span class="sodify" onclick="firehose_set_options('color', 'red')" title="Filter Firehose to entries rated red or better"></span><span class="icon-beaker pop1 " alt="Popularity" title="Filter Firehose to entries rated red or better" onclick="firehose_set_options('color', 'red')"><span></span></span> 
		</span>
		</span>
		<span class="story-byline">
	
				
			Posted
				by 
		
		
			
				  EditorDavid
			
		
		

		
		
		<time id="fhtime-123593424" datetime="on Saturday January 18, 2020 @09:03PM">on Saturday January 18, 2020 @09:03PM</time>
		
		
			 from the <span class="dept-text">friends-of-the-court</span> dept.
		
		</span>
	</div>
</header>

<div class="body" id="fhbody-123593424">
	
		
	

	
		
		<div id="text-123593424" class="p">
			
		 	
				Monday Red Hat and IBM jointly filed <a href="https://www.redhat.com/cms/managed-files/20200113165654112_18-956%20tsac%20International%20Business%20Machines%20Corp%20and%20Red%20Hat%20Inc.pdf">their own amicus brief</a> with the U.S. Supreme Court in the "Google vs. Oracle" case, arguing that APIs cannot be copyrighted.<br> <br>

"That simple, yet powerful principle has been a cornerstone of technological and economic growth for over sixty years. When published (as has been common industry practice for over three decades) or lawfully reverse engineered, they have spurred innovation through competition, increased productivity and economic efficiency, and connected the world in a way that has benefited commercial enterprises and consumers alike."<br> <br>

An anonymous reader quotes Red Hat's announcement of the brief:
<i>"The Federal Circuit's unduly narrow construction of 17 U.S.C. 102(b) is <a href="https://www.redhat.com/en/blog/red-hat-urges-us-supreme-court-support-unrestricted-use-software-interfaces">harmful to progress, competition, and innovation in the field of software development</a>," Red Hat stated in the brief. "IBM and Red Hat urge the Court to reverse the decision below on the basis that 17 U.S.C. 102(b) excludes software interfaces from copyright protection...."<br> <br>

The lower court incorrectly extended copyright protection to software interfaces. If left uncorrected, the lower court rulings could harm software compatibility and interoperability and have a chilling effect on the innovation represented by the open source community... Red Hat's significant involvement with Java development over the last 20 years has included extensive contributions to OpenJDK, an open source <a href="https://www.redhat.com/en/blog/history-and-future-openjdk">implementation of the Java platform</a>, and the development of Red Hat Middleware, a suite of Java-based middleware solutions to build, integrate, automate and deploy enterprise applications.  As an open source leader, Red Hat has a stake in the consistent and correct determination of the scope of copyright protection that applies to interfaces of computer programs, including the Java platform interface at stake in this case. <br> <br>

Open source software development relies on the availability of and unencumbered access to software interfaces, including products that are compatible with or interoperate with other computer products, platforms, and services...</i><br>
		 	
		</div>

		

		

		
			
		
	</div>
	<aside class="grid_24 view_mode">
		
			<div class="units-12 story-detail-tags">
				<span id="sharethis-123593424" class="">
					
						

						

						
							<div class="story-controls">
								<div
								  class="janrainSocialPlaceholder"
								  data-janrain-url="https://linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable"
								  data-janrain-title="Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable"
								  data-janrain-message="Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable @slashdot"
								></div>
							</div>
						
					
				</span>

				<div class="story-tags">
					<div class="tright tw">
						
							<span class="tright tags">
								
									<menu type="toolbar" class="edit-bar">
		<span id="tagbar-123593424" class="tag-bar none">
			<a  class="topic tag" rel="statictag" href="//slashdot.org/tag/" target="_blank"></a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/court" target="_blank">court</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/google" target="_blank">google</a>
<a  class="popular tag" rel="statictag" href="//slashdot.org/tag/ibm" target="_blank">ibm</a>

		</span>
		
			<a class="edit-toggle" href="/my/login/" onclick="show_login_box();return false;">
				<span class="icon-tag btn collapse"></span>
			</a>
		
		
		<div class="tag-menu">
			<input class="tag-entry default" type="text" value="apply tags">
		</div>
		

		
		

	</menu>
								
							</span>
						
					</div>
				</div>
			</div>

			
				
				
				
			 	
					<section class="grid_24" id="newa2footerv2">
						<div class="grid_6 pr">
							<h3><a title="Previous story" href="//developers.slashdot.org/story/20/01/18/0123210/slate-announces-list-of-the-30-most-evil-tech-companies?sdsrc=prev">&larr;</a></h3>
						</div>
						<div class="grid_12 rl">
							<h3>Related Links</h3>
						</div>
						<div class="grid_6 ns">
							<h3><a title="Next story" href="//news.slashdot.org/story/20/01/18/1753246/another-project-goes-private-amara-stops-being-developed-as-open-source?sdsrc=next">&rarr;</a></h3>
						</div>
						<div class="grid_6">
							<span class="c">
								<a href="//developers.slashdot.org/story/20/01/18/0123210/slate-announces-list-of-the-30-most-evil-tech-companies?sdsrc=prev">Slate Announces List of The 30 Most Evil Tech Companies </a>
							</span>
						</div>
						<div class="grid_12">
							<span class="c">
								
								
									<h3><a href="//yro.slashdot.org/story/20/01/13/228234/eff-files-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable?sdsrc=rel">EFF Files Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable</a></h3><script type="text/javascript">
		(function($){
			$('.js_disp_only').show();
			$('a.jshandle_related').on('click', '', function(e) {
				e.preventDefault();
				var url = $(this).data('goto-url');
				window.location = url
			});
		})($j);
	</script>
								
							</span>
						</div>
						<div class="grid_6">
							<span class="c">
								
									<a href="//news.slashdot.org/story/20/01/18/1753246/another-project-goes-private-amara-stops-being-developed-as-open-source?sdsrc=next">Another Project Goes Private: Amara Stops Being Developed As Open Source</a>
								
							</span>
						</div>
					</section>
				
			
		
	</aside>
	



	</article>
			</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: BEGIN RIGHT RAIL -->
	<aside id="slashboxes" class="rail-right">
		
                    <div id="slashboxesin" class="yui-b">
                            
                            
                            
                    </div>
		    <div class="railad adwrap-unviewed">
<div id='div-gpt-ad-300x250_a'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-300x250_a');});</script></div>
</div>
		    <div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
	if ( isAdBlockActive) {
		window._taboola = window._taboola || [];
		_taboola.push({
			mode: 'thumbnails-rr2',
			container: 'taboola-below-article-thumbnails',
			placement: 'Below Article Thumbnails',
			target_type: 'mix'
		});
	};
</script>
		
	</aside>
		<!-- SMACKS: END RIGHT RAIL -->
</div>
<!-- END STORY CONTENT -->

<!-- THIS IS THE LOCATION FOR THE NEW STORY_B CODE -->
<div class="adwrap">
<div id='div-gpt-ad-728x90_b'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_b');});</script></div>
</div>
<div id="stackcommerce-adwrap" style="display:none;">
    <div style="margin:auto;max-width:970px;max-height:250px;">
        <div data-sc-widget data-publisher-id="66" data-categories="88,90" data-items-per-page="4" data-col-count="4" data-utm-source="slashdot.org" data-utm-content="story-deal-feed"></div>
    </div>
</div>
<script type="text/javascript">
if (!window.is_euro_union) {
    if (isAdBlockActive) {
        $.ajax({
            url: '/ajax.pl?op=nel',
            success: function(html){
                if(html){
                    $('#firehoselist article').eq(0).after(html);
                } else {
                    (function () {
                        var stackCommerceDiv = document.getElementById('stackcommerce-adwrap');
                        stackCommerceDiv.style = '';
                        var stackCommerce = document.createElement('script');
                        stackCommerce.async = true;
                        stackCommerce.type = 'text/javascript';
                        stackCommerce.src = 'https://widgets.stackcommerce.com/js-deal-feed/0.1/widget.js';
                        var node = document.getElementsByTagName('script')[0];
                        node.parentNode.insertBefore(stackCommerce, node);
                    })();
                }
            }
        });
    };
}
</script>
<!--------------------------->


<!-- SMACKS: BEGIN COMMENTS CONTAINER -->
<div class="container">
	<!-- SMACKS: BEGIN COMMENTS SECTION -->
	<div class="main-wrap">
		<div class="main-content">
			<div id="comments" class="a2commentwrap">
			<div>
					<a name="comments"></a>
<div id="comments" class="container">
	<div class="main-wrap">
		<div class="main-content">
			<section class="d2incommentspl">
				<div class="commentwrap" id="commentwrap">
					
						<div class="commentBox">
							<div class="title hide">
								<h4>
									
										<span class="escape-link"><a href="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable" title="Back to Article - Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable">Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable</a></span>
									
									<span class="commentBoxLinks"><a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_d"></span> More</a>



	| <span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//linux.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a></span>
								</h4>
							</div>
						</div>
					

					<section class="grid_24" id="d2header"><div>
						
							<h2 class="commentspl test"><a title="Back to Article - Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable" href="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable">Red Hat and IBM Jointly File Another Amicus Brief In Google v. Oracle, Arguing APIs Are Not Copyrightable</a></h2>
						
						<nav class="grid_24">
							<div class="grid_14 widthauto">
							
						 		<span class="ind"></span><a class="btn first" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
							
							<!-- <a href="//linux.slashdot.org/search.pl?op=comments&amp;sid=15607490" class="btn">Search <span class="totalcommentcnt">41</span> Comments</a> -->
							
								
									<a href="#" onclick="D2.ajaxFetchComments(0,1,'','',-1); return false" class="btn" id="d2loadall">Load All Comments</a>
								
							
							
								</div>
								<div class="grid_10 d1or2">
							

							
								<div id="d2out" class="horizontal rooted grid_15">
									<div id="d2act" class="hide">
										<div class="loki" id="gods">
											<script type="text/javascript">
												 $(function(){
													 D2.slider = new D2.Slider(
														 D2.user_threshold(),
														 D2.user_highlightthresh(),
														 'x'
													 );
												 });
											</script>
											<div id="bones" class="grid_12">
												<div class="ccw-count-container grid_24">
													<span id="ccw-full-count-text" class="grid_8 ccw-count-text tcenter"><span></span><span id="ccw-full-phrase">&nbsp;Full</span></span>
													<span id="ccw-abbr-count-text" class="grid_8 ccw-count-text"><span></span><span id="ccw-abbr-phrase">&nbsp;Abbreviated</span></span>
													<span id="ccw-hide-count-text" class="grid_8 ccw-count-text tleft"><span></span><span id="ccw-hide-phrase">&nbsp;Hidden</span></span>
												</div>
												<div id="ccw">
													<div id="ccw-body" class="ccw-core">
														<div id="ccw-panel-container" class="ccw-core">
															<div id="ccw-full-panel" class="ccw-panel">
																/Sea<div class="ccw-panel-border"></div>
																<div id="ccw-full-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-abbr-panel" class="ccw-panel">
																<div class="ccw-panel-border"></div>
																<div id="ccw-abbr-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
															<div id="ccw-hide-panel" class="ccw-panel">
																<div id="ccw-hide-count-pos" class="ccw-core-pos ccw-count-pos"></div>
															</div>
														</div>
														<div id="ccw-control" class="ccw-core">
															<div id="ccw-centering-rail" class="ccw-core">
																<div id="ccw-hide-bar-pos" class="ccw-core-pos">
																	<div id="ccw-hide-bar" class="ccw-bar">
																		<div id="ccw-hide-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-hide-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(HIDE_BAR, +1)"></div>
																		<div id="ccw-hide-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(HIDE_BAR, -1)"></div>
																	</div>
																</div>
																<div id="ccw-abbr-bar-pos" class="ccw-core-pos">
																	<div id="ccw-abbr-bar" class="ccw-bar">
																		<div id="ccw-abbr-bar-tab" class="ccw-bar-tab"></div>
																		<div class="ccwa"></div>
																		<div class="ccwb"></div>
																		<div id="ccw-abbr-bar-upzone" class="ccw-upzone" onclick="D2.slider.stepTHT(ABBR_BAR, +1)"></div>
																		<div id="ccw-abbr-bar-downzone" class="ccw-downzone" onclick="D2.slider.stepTHT(ABBR_BAR, -1)"></div>
																	</div>
																</div>
															</div>
														</div>
													</div>
													<div class="ccw-score-label grid_24">
														<div class="grid_3"><span class="sc">Score:</span></div>
														<div class="grid_3">5<span class="lg"></span></div>
														<div class="grid_3">4<span class="lg"></span></div>
														<div class="grid_3">3<span class="lg"></span></div>
														<div class="grid_3">2<span class="lg"></span></div>
														<div class="grid_3">1<span class="lg"></span></div>
														<div class="grid_3">0<span class="lg"></span></div>
														<div class="grid_3">-1<span class="lg"></span></div>
													</div>
												</div>
											</div>
											<div class="commentControlFooter">
												<a href="#" onclick="D2.ajaxFetchComments(0,1); return false"><span id="more_comments_num_c"></span> More</a>



	| <span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Reply</a>


	<a class="login"  href="//linux.slashdot.org/login.pl" onclick="show_login_box(); return false">Login</a><div id="login_cover" class="hide" onclick="hide_login_box()"></div>
<div id="login_box" class="hide">
	<div id="login_box_content">
		<div id='embbeded_login_modal' class="hide">
<form action="https://slashdot.org/my/login" method="post" onsubmit="if (global_returnto) { this.returnto.value = global_returnto }" class="embedded"><fieldset style="-webkit-border-radius:10px 10px 0 0;border-radius:10px 10px 0 0;-moz-border-radius:10px 10px 0 0">
<div style='height:25px;'>&nbsp;</div>
    <input type="hidden" name="returnto" value="//linux.slashdot.org/comments.pl?sid=15607490">
    <input type="hidden" name="op" value="userlogin">
    <p>
        <label class="fleft" for="unickname">Nickname:</label>
        <input type="text" name="unickname" value="">
    </p>
    <p>
        <label class="fleft" for="upasswd">Password:</label>
        <input type="password" name="upasswd" placeholder="6-1024 characters long">
    </p>
    <label class="checkbox"><input type="checkbox" name="login_temp" value="yes"> Public Terminal</label>
    <br>
    <hr>
    <input type="submit" name="userlogin" value="Log In" class="fno"> <a href="//slashdot.org/my/mailpassword" class="btn link" onclick="getModalPrefs('sendPasswdModal', 'Retrieve Password', 1); return false;">Forgot your password?</a>
</fieldset></form>

<div id="janrainEngageEmbed"></div>
<div class="actions">
 <a class="ico close" onclick="hide_login_slider();" href=""><span>Close</span></a>
</div>
</div>
		<div class="actions">
			<a class="ico close" href="#" onclick="hide_login_box(); return false"><span>Close</span></a>
		</div>
	</div>
</div>
<script type="text/javascript">logged_in = 0</script>
											</div>
											<div id="commentControlBoxStatus" class="hide"></div>
										</div>
									</div>
								</div>
							
							
							<a href="//linux.slashdot.org/search.pl?op=comments&amp;sid=15607490" class="ui-icon search_comments">Search <span class="totalcommentcnt">41</span> Comments</a>
							
								<a class="pref ui-icon-w" href="//linux.slashdot.org/users.pl" onclick="show_login_box(); $('#modal_box').addClass('login'); return false;">Log In/Create an Account</a>
							
						</div>
					</nav>
					<section id="besttabs" class="grid_24">
						<span class="legend">Comments Filter:</span>
						<ul class="besttabslist">
							<li class="active">
								<a href="#" data-filter-url="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable#comments">All</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable/insightful-comments#comments">Insightful</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable/informative-comments#comments">Informative</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable/interesting-comments#comments">Interesting</a>
							</li>
						
							<li >
								<a href="" data-filter-url="//linux.slashdot.org/story/20/01/19/0212233/red-hat-and-ibm-jointly-file-another-amicus-brief-in-google-v-oracle-arguing-apis-are-not-copyrightable/funny-comments#comments">Funny</a>
							</li>
						
					</ul>
					<script>
					(function($){
						$('#besttabs').show();
						$('.besttabslist').on('click', 'li a', function(e){
							e.preventDefault();
							var url = $(this).data('filter-url');
							//console.log('URL= ', url);
							$(this)
								.closest('ul').find('li').removeClass('active')
								.end()
								.closest('li').addClass('active');
							window.location = url;
						});
					})($j);
					</script>
			</section>
				<aside class="grid_24">
					<p>
						<small><strong>The Fine Print:</strong> The following comments are owned by whoever posted them.  We are not responsible for them in any way.</small>
					</p>
				</aside>
			</section>
			
		</div>
	</div>
</div><script src="//a.fsdn.com/sd/comments-minified.js?4f1bc126f9ccc5b3" type="text/javascript"></script>


<script type="text/javascript">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</script>




	
	
	
	
		<ul id="commentlisting" class="d2">
			<li id="tree_59633872" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633872" class="commentstatus"></div>
<div id="comment_59633872" class="cw">
	<div id="comment_top_59633872" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633872" name="comment_link_59633872" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633872" onclick="return D2.setFocusComment(59633872)" >Jointly?</a>


		 	<span id="comment_score_59633872" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633872); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~javab0y">javab0y</a>  <span class="uid"><a href="//slashdot.org/~javab0y">( 708376 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633872">		
		on Saturday January 18, 2020 @09:20PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633872">#59633872</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633872">Isn't Red Hat the same company as IBM?</div>
	</div>

	<div class="commentSub" id="comment_sub_59633872">
<span class="ind"></span><a id="reply_link_59633872" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633872" onclick="D2.replyTo(59633872); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Jointly? by javab0y @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633872" data-title="Jointly?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Jointly? by javab0y" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633872" data-title="Jointly?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Jointly? by javab0y" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633872" data-title="Jointly?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633872" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633872" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633872" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633872"></div>

<ul id="group_59633872">
	<li id="hiddens_59633872" class="hide"></li>
</ul>

<ul id="commtree_59633872"><li id="tree_59633914" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633914" class="commentstatus"></div>
<div id="comment_59633914" class="cw">
	<div id="comment_top_59633914" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633914" name="comment_link_59633914" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633914" onclick="return D2.setFocusComment(59633914)" >Re:Jointly?</a>


		 	<span id="comment_score_59633914" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633914); return false"><span class=opt>Score:</span>5</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Aighearach">Aighearach</a>  <span class="uid"><a href="//slashdot.org/~Aighearach">( 97333 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633914">		
		on Saturday January 18, 2020 @09:48PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633914">#59633914</a>)
		<small><a href="http://rubypanther.com/" title="http://rubypanther.com/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633914"><p>Nope. IBM bought all the RedHat shares. That doesn't automatically make them a single legal entity. They could do that if they wanted, but it would be more normal to keep it as a subsidiary. It is usually only direct competitors where one succeeded and the other failed and got bought where the victor disbands the loser. Like Microchip eating Atmel and turning off their website out of spite.</p><p>This was a friendly merger by companies with different strengths and products, but with shared long-term goals and strategies. If they want to roll it into one, it will take years to do so because they wouldn't want to cause any damage. But both brands have value, so it is unlikely.</p><p>Just like if I owned two business that were both impacted by something, I might submit a joint amicus brief that represents both of them.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633914">
<span class="ind"></span><a id="reply_link_59633914" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633914" onclick="D2.replyTo(59633914); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=59633872" onclick="return D2.selectParent(59633872)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:Jointly? by Aighearach @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633914" data-title="Re:Jointly?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:Jointly? by Aighearach" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633914" data-title="Re:Jointly?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:Jointly? by Aighearach" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633914" data-title="Re:Jointly?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633914" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633914" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633914" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633914"></div>

<ul id="group_59633914">
	<li id="hiddens_59633914" class="hide"></li>
</ul>

</li></ul></li><li id="tree_59633904" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633904" class="commentstatus"></div>
<div id="comment_59633904" class="cw">
	<div id="comment_top_59633904" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633904" name="comment_link_59633904" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633904" onclick="return D2.setFocusComment(59633904)" >copyrighting APIs</a>


		 	<span id="comment_score_59633904" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633904); return false"><span class=opt>Score:</span>5</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~lkcl">lkcl</a>  <span class="uid"><a href="//slashdot.org/~lkcl">( 517947 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633904">		 &lt;<a href="mailto:lkcl%40lkcl.net">lkcl@lkcl.net</a>&gt;
		on Saturday January 18, 2020 @09:38PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633904">#59633904</a>)
		<small><a href="http://lkcl.net/" title="http://lkcl.net/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633904"><p>i've mentioned this before, however it's worth repeating: the implications for copyrighting of APIs goes far deeper than most people realise.</p><p>examples include actual instruction sets.  instruction sets - the actual binary bits of executables and the means and method of "interpreting" those - are an "API".  the instructions *are* an "interface" (to the hardware - the actual core that executes those instructions) which is "programmable" by "applications" (aka "binaries").</p><p>thus, llvm, gcc, microsoft's visual studio *and* sdcc *and* every single other compiler ever written would, in the eyes of US Law, overnight become criminally-infringing of every single "copyright" holder's instruction set for which they offer compiler support.  Intel, ARM, MIPS, POWER, OpenRISC, SPARC - all of them - because the "instructions" (the assembly code, aka an "API") would *overnight* become copyrighted material for which NO PRIOR STATEMENT on the license of that copyrighted material had ever previously been stated.</p><p>language translators (.NET, WASM) would similarly become criminally-infringing because every *language* is an API.</p><p>pypy would become criminally-infringing because they implemented the python software foundation APIs *without permission that they never previously required* and on which the python software foundation never predicted that they would ever need to make a clear and explicit copyright statement on.</p><p>any code on any git repository that implements an API (kubernetes, google cloud APIs, pyro, DCE/RPC, MSRPC, SOAP, php libraries, *EVERYTHING*) now has to make a clear statement as to how and when licensees may use that (now newly copyrighted) material.</p><p>the list goes on and on.  copyright law is very clear: if you don't make a statement (don't issue a license), then potential licencees *must* contact you each and every time to request permission.</p><p>suddenly changing the way as to what is copyrightable to include something as massive as "APIs" where *nobody* - in the entire world - has ever issued a license or a statement about the APIs - is a total nightmare.</p><p>the disruption that this will cause *to Oracle's own business* gives you some idea of how stupid and greedy they really are.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633904">
<span class="ind"></span><a id="reply_link_59633904" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633904" onclick="D2.replyTo(59633904); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="copyrighting APIs by lkcl @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633904" data-title="copyrighting APIs">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="copyrighting APIs by lkcl" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633904" data-title="copyrighting APIs">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="copyrighting APIs by lkcl" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633904" data-title="copyrighting APIs">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633904" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633904" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633904" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633904"></div>

<ul id="group_59633904">
	<li id="hiddens_59633904" class="hide"></li>
</ul>

<ul id="commtree_59633904"><li id="tree_59633954" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633954" class="commentstatus"></div>
<div id="comment_59633954" class="cw">
	<div id="comment_top_59633954" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633954" name="comment_link_59633954" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633954" onclick="return D2.setFocusComment(59633954)" >Re:copyrighting APIs</a>


		 	<span id="comment_score_59633954" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633954); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~suutar">suutar</a>  <span class="uid"><a href="//slashdot.org/~suutar">( 1860506 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633954">		
		on Saturday January 18, 2020 @10:35PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633954">#59633954</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633954"><p>seems like it would also mean that IBM owns the copyrights to the SQL language... that would be a kick in Oracle's pants.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633954">
<span class="ind"></span><a id="reply_link_59633954" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633954" onclick="D2.replyTo(59633954); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=59633904" onclick="return D2.selectParent(59633904)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re:copyrighting APIs by suutar @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633954" data-title="Re:copyrighting APIs">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re:copyrighting APIs by suutar" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633954" data-title="Re:copyrighting APIs">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re:copyrighting APIs by suutar" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633954" data-title="Re:copyrighting APIs">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633954" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633954" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633954" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633954"></div>

<ul id="group_59633954">
	<li id="hiddens_59633954" class="hide"></li>
</ul>

</li><li id="tree_59633970" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59633970" class="commentstatus"></div>
<div id="comment_59633970" class="cw">
</div>

<div id="replyto_59633970"></div>

<ul id="group_59633970">
	<li id="hiddens_59633970" class="hide"></li>
</ul>

</li><li id="tree_59633980" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633980" class="commentstatus"></div>
<div id="comment_59633980" class="cw">
	<div id="comment_top_59633980" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633980" name="comment_link_59633980" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633980" onclick="return D2.setFocusComment(59633980)" >Re:</a>


		 	<span id="comment_score_59633980" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633980); return false"><span class=opt>Score:</span>3</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Keill">Keill</a>  <span class="uid"><a href="//slashdot.org/~Keill">( 920526 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633980"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633980">One of the problems is that I've never really seen anyone, anywhere, use the true description for what is trying to happen: to copyright rules of language, rather than when a language is specifically applied.  This is what an API is - a set of rules of how to apply such existing communication used with computers.  The basic rules of the English language is an API, just for humans rather than computers, and trying to copyright that, is the equivalent of what is happening here - in addition to any other addit</div>
	</div>

	<div class="commentSub" id="comment_sub_59633980">

</div>
</div>

<div id="replyto_59633980"></div>

<ul id="group_59633980">
	<li id="hiddens_59633980" class="hide"></li>
</ul>

<ul id="commtree_59633980"><li id="tree_59634252" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634252" class="commentstatus"></div>
<div id="comment_59634252" class="cw">
	<div id="comment_top_59634252" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634252" name="comment_link_59634252" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634252" onclick="return D2.setFocusComment(59634252)" >Re:</a>


		 	<span id="comment_score_59634252" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634252); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~olfdag_kerfunke">olfdag_kerfunke</a>  <span class="uid"><a href="//slashdot.org/~olfdag_kerfunke">( 6260520 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634252"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634252">I think this is because understanding copyright requires highly abstract thinking that most people simply are not capable of. Attempting to form an argument by extension to absurdity may not be 100% valid, but it is important to note where things could lead, albeit however unlikely that may be.

I have attempted to point this out myself: <a href="https://slashdot.org/comments.pl?sid=15574938&amp;cid=59618302" title="slashdot.org" rel="nofollow">https://slashdot.org/comments....</a> [slashdot.org] so it isn't that it goes entirely unrecognized, but rather merely seemingly insignificantly so.</div>
	</div>

	<div class="commentSub" id="comment_sub_59634252">

</div>
</div>

<div id="replyto_59634252"></div>

<ul id="group_59634252">
	<li id="hiddens_59634252" class="hide"></li>
</ul>

</li></ul></li><li id="tree_59634074" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634074" class="commentstatus"></div>
<div id="comment_59634074" class="cw">
	<div id="comment_top_59634074" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634074" name="comment_link_59634074" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634074" onclick="return D2.setFocusComment(59634074)" >Re: copyrighting APIs</a>


		 	<span id="comment_score_59634074" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634074); return false"><span class=opt>Score:</span>2</a>, Redundant)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~guruevi">guruevi</a>  <span class="uid"><a href="//slashdot.org/~guruevi">( 827432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634074"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634074"><p>That isn't entirely true, some of your examples implicitly or explicitly allow copying of any/all parts of the API.</p><p>The problem here is that Google actually copied Java wholesale which was under a very murky "open" license and then relicensed it and partially rewrote it later on.</p><p>Google is trying to spin this into "we just copied the API" but actually also copied the documentation. This wasn't a "Compaq vs IBM" clean room implementation of a black box, this was "copy, paste including the bits we don't actuall<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634074">

</div>
</div>

<div id="replyto_59634074"></div>

<ul id="group_59634074">
	<li id="hiddens_59634074" class="hide"></li>
</ul>

<ul id="commtree_59634074"><li id="tree_59634172" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59634172" class="commentstatus"></div>
<div id="comment_59634172" class="cw">
	<div id="comment_top_59634172" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634172" name="comment_link_59634172" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634172" onclick="return D2.setFocusComment(59634172)" >Re: copyrighting APIs</a>


		 	<span id="comment_score_59634172" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634172); return false"><span class=opt>Score:</span>4</a>, Informative)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~The+Evil+Atheist">The Evil Atheist</a>  <span class="uid"><a href="//slashdot.org/~The+Evil+Atheist">( 2484676 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634172">		
		on Sunday January 19, 2020 @02:19AM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634172">#59634172</a>)
		<small><a href="http://worldengineer.me/" title="http://worldengineer.me/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634172"><p><div class="quote"><p>The problem here is that Google actually copied Java wholesale</p></div><p>But the courts have already decided the problem was APIs.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634172">
<span class="ind"></span><a id="reply_link_59634172" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59634172" onclick="D2.replyTo(59634172); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=59634074" onclick="return D2.selectParent(59634074)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Re: copyrighting APIs by The Evil Atheist @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59634172" data-title="Re: copyrighting APIs">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Re: copyrighting APIs by The Evil Atheist" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59634172" data-title="Re: copyrighting APIs">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Re: copyrighting APIs by The Evil Atheist" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59634172" data-title="Re: copyrighting APIs">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59634172" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59634172" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59634172" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59634172"></div>

<ul id="group_59634172">
	<li id="hiddens_59634172" class="hide"></li>
</ul>

</li><li id="tree_59635060" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59635060" class="commentstatus"></div>
<div id="comment_59635060" class="cw">
	<div id="comment_top_59635060" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59635060" name="comment_link_59635060" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59635060" onclick="return D2.setFocusComment(59635060)" >Re:</a>


		 	<span id="comment_score_59635060" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59635060); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Immerman">Immerman</a>  <span class="uid"><a href="//slashdot.org/~Immerman">( 2627577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59635060"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59635060"><p>The Apache license is about as firmly open as you can get, and Google wholesale copied Java from the Apache Harmony project, as explicitly permitted within the license. Not Oracle's Java, a fully open source re-implementation of it.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59635060">

</div>
</div>

<div id="replyto_59635060"></div>

<ul id="group_59635060">
	<li id="hiddens_59635060" class="hide"></li>
</ul>

</li></ul></li><li id="tree_59634498" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634498" class="commentstatus"></div>
<div id="comment_59634498" class="cw">
	<div id="comment_top_59634498" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634498" name="comment_link_59634498" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634498" onclick="return D2.setFocusComment(59634498)" >Re:</a>


		 	<span id="comment_score_59634498" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634498); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~loufoque">loufoque</a>  <span class="uid"><a href="//slashdot.org/~loufoque">( 1400831 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634498"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634498"><p>That doesn't sound weird at all to me.</p><p>Yes, you'd either need a license to target a language or for its author to explicitly publish its specifications under an open license.</p><p>In practice, most processor manufacturers would just do the latter.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634498">

</div>
</div>

<div id="replyto_59634498"></div>

<ul id="group_59634498">
	<li id="hiddens_59634498" class="hide"></li>
</ul>

</li><li id="hidestring_59633904"><noscript><b class='more'><span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=59633904">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_59633910" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633910" class="commentstatus"></div>
<div id="comment_59633910" class="cw">
	<div id="comment_top_59633910" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633910" name="comment_link_59633910" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633910" onclick="return D2.setFocusComment(59633910)" >IBM</a>


		 	<span id="comment_score_59633910" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633910); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span>Anonymous Coward</span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633910"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633910"><p>The legal department at IBM must be in a constant state of orgasmal bliss over this one.</p><p>If oracle does not win, it stays business as usual.</p><p>If oracle does win, they will owe IBM royalties for SQL backdated to the mid 80s, on top of all the $150,000 copyright violation fines per oracle SQL license ever sold.<br>SQL is just an API after all, one owned by IBM that oracle is trying their best to prove they have infringed.<br>Oracle is setting themselves up for hundreds of trillions of dollars in legal fines by winning,<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633910">

</div>
</div>

<div id="replyto_59633910"></div>

<ul id="group_59633910">
	<li id="hiddens_59633910" class="hide"></li>
</ul>

<ul id="commtree_59633910"><li id="tree_59633926" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633926" class="commentstatus"></div>
<div id="comment_59633926" class="cw">
	<div id="comment_top_59633926" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633926" name="comment_link_59633926" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633926" onclick="return D2.setFocusComment(59633926)" >Re:</a>


		 	<span id="comment_score_59633926" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633926); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jmccue">jmccue</a>  <span class="uid"><a href="//slashdot.org/~jmccue">( 834797 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633926"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633926"><p><div class="quote"><p>If oracle does win, they will owe IBM royalties for SQL</p></div><p>I would not consider SQL an API, unless you are taking about how it accesses Rational Databases, which I think IBM also came up with.</p><p>I expect a very narrow ruling if Oracle wins, but if not good time to become a Corp. Lawyer</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633926">

</div>
</div>

<div id="replyto_59633926"></div>

<ul id="group_59633926">
	<li id="hiddens_59633926" class="hide"></li>
</ul>

<ul id="commtree_59633926"><li id="tree_59634192" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59634192" class="commentstatus"></div>
<div id="comment_59634192" class="cw">
</div>

<div id="replyto_59634192"></div>

<ul id="group_59634192">
	<li id="hiddens_59634192" class="hide"></li>
</ul>

</li><li id="hidestring_59633926"><noscript><b class='more'><span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=59633926">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li></ul></li><li id="tree_59633916" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633916" class="commentstatus"></div>
<div id="comment_59633916" class="cw">
	<div id="comment_top_59633916" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633916" name="comment_link_59633916" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633916" onclick="return D2.setFocusComment(59633916)" >Best description of Oracle I've seen</a>


		 	<span id="comment_score_59633916" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633916); return false"><span class=opt>Score:</span>4</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Sebby">Sebby</a>  <span class="uid"><a href="//slashdot.org/~Sebby">( 238625 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633916">		
		on Saturday January 18, 2020 @09:49PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633916">#59633916</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633916">Goes something like this:<p>
<i>"Oracle is a law firm with a software side business."</i> </p><p>(Wish I could find the original quote so that I could properly attribute it).</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633916">
<span class="ind"></span><a id="reply_link_59633916" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633916" onclick="D2.replyTo(59633916); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Best description of Oracle I've seen by Sebby @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633916" data-title="Best description of Oracle I've seen">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Best description of Oracle I've seen by Sebby" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633916" data-title="Best description of Oracle I've seen">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Best description of Oracle I've seen by Sebby" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633916" data-title="Best description of Oracle I've seen">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633916" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633916" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633916" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633916"></div>

<ul id="group_59633916">
	<li id="hiddens_59633916" class="hide"></li>
</ul>

<ul id="commtree_59633916"><li id="tree_59633918" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633918" class="commentstatus"></div>
<div id="comment_59633918" class="cw">
	<div id="comment_top_59633918" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633918" name="comment_link_59633918" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633918" onclick="return D2.setFocusComment(59633918)" >Found it!</a>


		 	<span id="comment_score_59633918" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633918); return false"><span class=opt>Score:</span>4</a>, Funny)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Sebby">Sebby</a>  <span class="uid"><a href="//slashdot.org/~Sebby">( 238625 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633918">		
		on Saturday January 18, 2020 @09:53PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633918">#59633918</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633918"><p> <a href="https://news.ycombinator.com/item?id=21966351" title="ycombinator.com">Here</a> [ycombinator.com] it is:</p><p> <i>"Oracle is the #1 law firm in Silicon Valley. Strangely, they seem to have a software side business."</i> </p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633918">
<span class="ind"></span><a id="reply_link_59633918" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633918" onclick="D2.replyTo(59633918); return false;">Reply to This</a> <span class="ind"></span><a class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;cid=59633916" onclick="return D2.selectParent(59633916)">Parent</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Found it! by Sebby @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633918" data-title="Found it!">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Found it! by Sebby" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633918" data-title="Found it!">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Found it! by Sebby" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633918" data-title="Found it!">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633918" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633918" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633918" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633918"></div>

<ul id="group_59633918">
	<li id="hiddens_59633918" class="hide"></li>
</ul>

</li><li id="tree_59633922" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633922" class="commentstatus"></div>
<div id="comment_59633922" class="cw">
	<div id="comment_top_59633922" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633922" name="comment_link_59633922" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633922" onclick="return D2.setFocusComment(59633922)" >Re:</a>


		 	<span id="comment_score_59633922" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633922); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Local+ID10T">Local ID10T</a>  <span class="uid"><a href="//slashdot.org/~Local+ID10T">( 790134 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633922"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633922"><p>O ne<br>R ich<br>A sshole<br>C alled<br>L arry<br>E llison</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633922">

</div>
</div>

<div id="replyto_59633922"></div>

<ul id="group_59633922">
	<li id="hiddens_59633922" class="hide"></li>
</ul>

<ul id="commtree_59633922"><li id="tree_59633962" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633962" class="commentstatus"></div>
<div id="comment_59633962" class="cw">
	<div id="comment_top_59633962" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633962" name="comment_link_59633962" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633962" onclick="return D2.setFocusComment(59633962)" >Re:</a>


		 	<span id="comment_score_59633962" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633962); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Sebby">Sebby</a>  <span class="uid"><a href="//slashdot.org/~Sebby">( 238625 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633962"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633962"><p><div class="quote"><p>O ne
R ich
A sshole
C alled
L arry
E llison</p></div><p>A (very) close second!</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633962">

</div>
</div>

<div id="replyto_59633962"></div>

<ul id="group_59633962">
	<li id="hiddens_59633962" class="hide"></li>
</ul>

</li></ul></li><li id="tree_59633972" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633972" class="commentstatus"></div>
<div id="comment_59633972" class="cw">
	<div id="comment_top_59633972" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633972" name="comment_link_59633972" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633972" onclick="return D2.setFocusComment(59633972)" >Thats not the best</a>


		 	<span id="comment_score_59633972" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633972); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ghoul">ghoul</a>  <span class="uid"><a href="//slashdot.org/~ghoul">( 157158 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633972"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633972"><p>The Best is " One Real Asshole Called Larry Ellison". Though its more of a backronym than a definition.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633972">

</div>
</div>

<div id="replyto_59633972"></div>

<ul id="group_59633972">
	<li id="hiddens_59633972" class="hide"></li>
</ul>

</li><li id="tree_59633982" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59633982" class="commentstatus"></div>
<div id="comment_59633982" class="cw">
</div>

<div id="replyto_59633982"></div>

<ul id="group_59633982">
	<li id="hiddens_59633982" class="hide"></li>
</ul>

<ul id="commtree_59633982"><li id="tree_59634168" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634168" class="commentstatus"></div>
<div id="comment_59634168" class="cw">
	<div id="comment_top_59634168" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634168" name="comment_link_59634168" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634168" onclick="return D2.setFocusComment(59634168)" >Re:</a>


		 	<span id="comment_score_59634168" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634168); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tricorn">tricorn</a>  <span class="uid"><a href="//slashdot.org/~tricorn">( 199664 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634168"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634168"><p>You are badly misinformed.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634168">

</div>
</div>

<div id="replyto_59634168"></div>

<ul id="group_59634168">
	<li id="hiddens_59634168" class="hide"></li>
</ul>

</li></ul></li><li id="tree_59634008" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59634008" class="commentstatus"></div>
<div id="comment_59634008" class="cw">
</div>

<div id="replyto_59634008"></div>

<ul id="group_59634008">
	<li id="hiddens_59634008" class="hide"></li>
</ul>

</li><li id="tree_59634018" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634018" class="commentstatus"></div>
<div id="comment_59634018" class="cw">
	<div id="comment_top_59634018" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634018" name="comment_link_59634018" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634018" onclick="return D2.setFocusComment(59634018)" >Re:</a>


		 	<span id="comment_score_59634018" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634018); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ArchieBunker">ArchieBunker</a>  <span class="uid"><a href="//slashdot.org/~ArchieBunker">( 132337 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634018"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634018"><p>They stole that title from IBM.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634018">

</div>
</div>

<div id="replyto_59634018"></div>

<ul id="group_59634018">
	<li id="hiddens_59634018" class="hide"></li>
</ul>

</li><li id="hidestring_59633916"><noscript><b class='more'><span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=59633916">2 replies</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_59633932" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633932" class="commentstatus"></div>
<div id="comment_59633932" class="cw">
	<div id="comment_top_59633932" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633932" name="comment_link_59633932" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633932" onclick="return D2.setFocusComment(59633932)" >SCotUS are you listening?</a>


		 	<span id="comment_score_59633932" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633932); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~The+New+Guy+2.0">The New Guy 2.0</a>  <span class="uid"><a href="//slashdot.org/~The+New+Guy+2.0">( 3497907 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633932"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633932"><p>This one is definitely headed the Supreme Court's way... both sides have plenty of money for lawyers, and there's significant interest on both sides as well.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633932">

</div>
</div>

<div id="replyto_59633932"></div>

<ul id="group_59633932">
	<li id="hiddens_59633932" class="hide"></li>
</ul>

<ul id="commtree_59633932"><li id="tree_59633952" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59633952" class="commentstatus"></div>
<div id="comment_59633952" class="cw">
</div>

<div id="replyto_59633952"></div>

<ul id="group_59633952">
	<li id="hiddens_59633952" class="hide"></li>
</ul>

</li><li id="hidestring_59633932"><noscript><b class='more'><span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=59633932">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_59633938" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633938" class="commentstatus"></div>
<div id="comment_59633938" class="cw">
	<div id="comment_top_59633938" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633938" name="comment_link_59633938" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633938" onclick="return D2.setFocusComment(59633938)" >The collection of APIs is copyrightable</a>


		 	<span id="comment_score_59633938" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633938); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~FeelGood314">FeelGood314</a>  <span class="uid"><a href="//slashdot.org/~FeelGood314">( 2516288 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633938"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633938">It would be terrible if the Java API were copyrighted.  IBM and Redhat are arguing that the harm done to society outweighs the benefit of allowing a collection of APIs to be copyrighted.  Note: an individual API isn't copyrightable, like a recipe or a dictionary entry most countries require a copyright to be more creative than that.  However an entire collection of recipes, or a dictionary or a set of APIs is a creative work and therefore worthy of copyright protection.  I hope Oracle loses but the law as i</div>
	</div>

	<div class="commentSub" id="comment_sub_59633938">

</div>
</div>

<div id="replyto_59633938"></div>

<ul id="group_59633938">
	<li id="hiddens_59633938" class="hide"></li>
</ul>

<ul id="commtree_59633938"><li id="tree_59633956" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59633956" class="commentstatus"></div>
<div id="comment_59633956" class="cw">
	<div id="comment_top_59633956" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633956" name="comment_link_59633956" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633956" onclick="return D2.setFocusComment(59633956)" >Re:</a>


		 	<span id="comment_score_59633956" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633956); return false"><span class=opt>Score:</span>3</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~suutar">suutar</a>  <span class="uid"><a href="//slashdot.org/~suutar">( 1860506 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633956"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633956"><p>A recipe (specifically an ingredients list and a minimal list of operations) is not copyrightable, but a book of them is, true, because someone decided which recipes to put in, added descriptions, pictures, more depth to the operations, etc. However there's nothing stopping you from making your own book with some or all of those recipes as long as you don't copy the creative parts. "pizza dough - 1/2 cup milk, 1.5 cup flour, 1 packet yeast, 4 tablespoons butter. Melt butter, add milk, warm milk/butter mixtu<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633956">

</div>
</div>

<div id="replyto_59633956"></div>

<ul id="group_59633956">
	<li id="hiddens_59633956" class="hide"></li>
</ul>

<ul id="commtree_59633956"><li id="tree_59634092" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634092" class="commentstatus"></div>
<div id="comment_59634092" class="cw">
	<div id="comment_top_59634092" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634092" name="comment_link_59634092" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634092" onclick="return D2.setFocusComment(59634092)" >Re: The collection of APIs is copyrightable</a>


		 	<span id="comment_score_59634092" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634092); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~guruevi">guruevi</a>  <span class="uid"><a href="//slashdot.org/~guruevi">( 827432 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634092"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634092"><p>Google did both though. They copied the API as well as its composition within their own product (Android), modified it and called it their own while the license, although open, doesn't allow them to just go about and modify the Java API</p><p>Microsoft did the same thing to Sun in the 90s (there was a thing called MS Java) and lost to Sun because they didn't conform to the "open" license. It was then decided the only way Java could be reimplemented is by a cleanroom implementation that isn't associated with the Ja<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634092">

</div>
</div>

<div id="replyto_59634092"></div>

<ul id="group_59634092">
	<li id="hiddens_59634092" class="hide"></li>
</ul>

<ul id="commtree_59634092"><li id="tree_59635088" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59635088" class="commentstatus"></div>
<div id="comment_59635088" class="cw">
	<div id="comment_top_59635088" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59635088" name="comment_link_59635088" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59635088" onclick="return D2.setFocusComment(59635088)" >Re:</a>


		 	<span id="comment_score_59635088" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59635088); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Immerman">Immerman</a>  <span class="uid"><a href="//slashdot.org/~Immerman">( 2627577 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59635088"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59635088"><p>&gt; It was then decided the only way Java could be reimplemented is by a cleanroom implementation that isn't associated with the Java brand name.</p><p>Is Google advertising anything associated with the Java brand name?   Pretty sure they called "their" language something completely different, which frees them from trademark law.  And Oracle has no copyright claims (other than trying for the API), because the implementation was copied from the firmly open Apache Harmony re-implementation.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59635088">

</div>
</div>

<div id="replyto_59635088"></div>

<ul id="group_59635088">
	<li id="hiddens_59635088" class="hide"></li>
</ul>

</li></ul></li><li id="tree_59634432" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634432" class="commentstatus"></div>
<div id="comment_59634432" class="cw">
	<div id="comment_top_59634432" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634432" name="comment_link_59634432" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634432" onclick="return D2.setFocusComment(59634432)" >Re:</a>


		 	<span id="comment_score_59634432" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634432); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~shentino">shentino</a>  <span class="uid"><a href="//slashdot.org/~shentino">( 1139071 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634432"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634432"><p>Tell that to the tetris company</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634432">

</div>
</div>

<div id="replyto_59634432"></div>

<ul id="group_59634432">
	<li id="hiddens_59634432" class="hide"></li>
</ul>

<ul id="commtree_59634432"><li id="tree_59634970" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634970" class="commentstatus"></div>
<div id="comment_59634970" class="cw">
	<div id="comment_top_59634970" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634970" name="comment_link_59634970" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634970" onclick="return D2.setFocusComment(59634970)" >Re:</a>


		 	<span id="comment_score_59634970" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634970); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~tepples">tepples</a>  <span class="uid"><a href="//slashdot.org/~tepples">( 727027 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634970"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634970"><p>Video game balance parameters are not necessary for interoperability, except in esports.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634970">

</div>
</div>

<div id="replyto_59634970"></div>

<ul id="group_59634970">
	<li id="hiddens_59634970" class="hide"></li>
</ul>

</li></ul></li></ul></li></ul></li><li id="tree_59633940" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633940" class="commentstatus"></div>
<div id="comment_59633940" class="cw">
	<div id="comment_top_59633940" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633940" name="comment_link_59633940" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633940" onclick="return D2.setFocusComment(59633940)" >SCO</a>


		 	<span id="comment_score_59633940" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633940); return false"><span class=opt>Score:</span>4</a>, Insightful)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~timeOday">timeOday</a>  <span class="uid"><a href="//slashdot.org/~timeOday">( 582209 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633940">		
		on Saturday January 18, 2020 @10:26PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633940">#59633940</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633940">Did 13 years of SCO suing IBM over Unix APIs teach us nothing?
<p>
(Also, why am I the first person who referenced this?  What has<nobr> <wbr></nobr>./ come to?)
</p><p>
<a href="https://en.wikipedia.org/wiki/SCO%E2%80%93Linux_disputes#SVRx_code_allegedly_in_Linux" title="wikipedia.org">https://en.wikipedia.org/wiki/...</a> [wikipedia.org]</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633940">
<span class="ind"></span><a id="reply_link_59633940" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633940" onclick="D2.replyTo(59633940); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="SCO by timeOday @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633940" data-title="SCO">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="SCO by timeOday" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633940" data-title="SCO">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="SCO by timeOday" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633940" data-title="SCO">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633940" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633940" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633940" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633940"></div>

<ul id="group_59633940">
	<li id="hiddens_59633940" class="hide"></li>
</ul>

<ul id="commtree_59633940"><li id="tree_59633986" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59633986" class="commentstatus"></div>
<div id="comment_59633986" class="cw">
</div>

<div id="replyto_59633986"></div>

<ul id="group_59633986">
	<li id="hiddens_59633986" class="hide"></li>
</ul>

</li><li id="hidestring_59633940"><noscript><b class='more'><span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=59633940">1 reply</a> beneath your current threshold.</b></noscript></li></ul></li><li id="tree_59633948" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633948" class="commentstatus"></div>
<div id="comment_59633948" class="cw">
	<div id="comment_top_59633948" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633948" name="comment_link_59633948" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633948" onclick="return D2.setFocusComment(59633948)" >Oracle's S3 compatibility API</a>


		 	<span id="comment_score_59633948" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633948); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Todd+Knarr">Todd Knarr</a>  <span class="uid"><a href="//slashdot.org/~Todd+Knarr">( 15451 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633948">		
		on Saturday January 18, 2020 @10:31PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633948">#59633948</a>)
		<small><a href="http://technical.silverglass.org/" title="http://technical.silverglass.org/" class="user_homepage_display">Homepage</a> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633948"><p>This one ought to be brought up during the case. Oracle themselves do exactly what they are claiming is copyright infringement: they created their own server implementation of AWS's S3 APIs for the express purpose of allowing customers with tools that worked with S3 to work with Oracle's Object Storage product without any code changes. That's exactly what Oracle's claiming Google did, create an implementation of an Oracle API that was compatible with that API. Let Oracle explain to the judges why it's OK for them to do it and not Google.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633948">
<span class="ind"></span><a id="reply_link_59633948" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633948" onclick="D2.replyTo(59633948); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Oracle's S3 compatibility API by Todd Knarr @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633948" data-title="Oracle's S3 compatibility API">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Oracle's S3 compatibility API by Todd Knarr" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633948" data-title="Oracle's S3 compatibility API">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Oracle's S3 compatibility API by Todd Knarr" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633948" data-title="Oracle's S3 compatibility API">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633948" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633948" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633948" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633948"></div>

<ul id="group_59633948">
	<li id="hiddens_59633948" class="hide"></li>
</ul>

<ul id="commtree_59633948"><li id="tree_59634014" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634014" class="commentstatus"></div>
<div id="comment_59634014" class="cw">
	<div id="comment_top_59634014" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634014" name="comment_link_59634014" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634014" onclick="return D2.setFocusComment(59634014)" >Re:</a>


		 	<span id="comment_score_59634014" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634014); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~mewsenews">mewsenews</a>  <span class="uid"><a href="//slashdot.org/~mewsenews">( 251487 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634014"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634014">With the amount of lawyers involved in this case I gotta imagine that will be one of the arguments they put forward.</div>
	</div>

	<div class="commentSub" id="comment_sub_59634014">

</div>
</div>

<div id="replyto_59634014"></div>

<ul id="group_59634014">
	<li id="hiddens_59634014" class="hide"></li>
</ul>

</li><li id="tree_59634264" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634264" class="commentstatus"></div>
<div id="comment_59634264" class="cw">
	<div id="comment_top_59634264" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634264" name="comment_link_59634264" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634264" onclick="return D2.setFocusComment(59634264)" >Re: Oracle's S3 compatibility API</a>


		 	<span id="comment_score_59634264" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634264); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~ToasterMonkey">ToasterMonkey</a>  <span class="uid"><a href="//slashdot.org/~ToasterMonkey">( 467067 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634264"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634264"><p>"An Oracle spokeswoman said that the S3 API was licensed under an Apache 2.0 license. She pointed us to the Amazon SDK for Java, which does indeed come with an Apache 2.0 license."</p><p>*shrug*</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634264">

</div>
</div>

<div id="replyto_59634264"></div>

<ul id="group_59634264">
	<li id="hiddens_59634264" class="hide"></li>
</ul>

<ul id="commtree_59634264"><li id="tree_59634376" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634376" class="commentstatus"></div>
<div id="comment_59634376" class="cw">
	<div id="comment_top_59634376" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634376" name="comment_link_59634376" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634376" onclick="return D2.setFocusComment(59634376)" >Re:</a>


		 	<span id="comment_score_59634376" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634376); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Todd+Knarr">Todd Knarr</a>  <span class="uid"><a href="//slashdot.org/~Todd+Knarr">( 15451 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634376"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634376"><p>That would be a problem for Oracle, though. OpenJDK, which is the open-source standard for the Java APIs, is licensed under the GPL. That would make Google's implementation eminently legal. Except for the small fact (which still hurts Oracle) that the SDK isn't the API and certainly isn't the server-side part of S3 which is what Oracle implemented. At most, having Amazon's SDK licensed under Apache 2.0 would grant Oracle the right to develop their own SDK to interact with Amazon's S3 servers. It wouldn't gr<span class="substr"> </span></p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634376">

</div>
</div>

<div id="replyto_59634376"></div>

<ul id="group_59634376">
	<li id="hiddens_59634376" class="hide"></li>
</ul>

</li><li id="tree_59634450" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634450" class="commentstatus"></div>
<div id="comment_59634450" class="cw">
	<div id="comment_top_59634450" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634450" name="comment_link_59634450" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634450" onclick="return D2.setFocusComment(59634450)" >Re:</a>


		 	<span id="comment_score_59634450" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634450); return false"><span class=opt>Score:</span>2</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~Solandri">Solandri</a>  <span class="uid"><a href="//slashdot.org/~Solandri">( 704621 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634450"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634450">Thing is, when Google did it, it was legal because Sun openly encouraged companies to use Java.  Oracle's argument is that the owner of the API can choose to revoke permission to use an API which they'd previously allowed.  So it really doesn't matter that Oracle has licensed the S3 API.  If they win, Amazon can simply say they're revoking the permission granted by that license, and Oracle will need to pay them a gazillion dollars if they wish to continue using it.</div>
	</div>

	<div class="commentSub" id="comment_sub_59634450">

</div>
</div>

<div id="replyto_59634450"></div>

<ul id="group_59634450">
	<li id="hiddens_59634450" class="hide"></li>
</ul>

</li></ul></li></ul></li><li id="tree_59633994" class="comment full contain"><span class="ind"></span>
<div id="comment_status_59633994" class="commentstatus"></div>
<div id="comment_59633994" class="cw">
	<div id="comment_top_59633994" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59633994" name="comment_link_59633994" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633994" onclick="return D2.setFocusComment(59633994)" >Use Oracle's own arguments against them?</a>


		 	<span id="comment_score_59633994" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59633994); return false"><span class=opt>Score:</span>5</a>, Interesting)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~jonwil">jonwil</a>  <span class="uid"><a href="//slashdot.org/~jonwil">( 467024 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59633994">		
		on Saturday January 18, 2020 @11:30PM (<span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59633994">#59633994</a>)
		<small> </small>
</span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59633994"><p>I wonder if IBM could claim (under "API copyright" as Oracle is defining it) that Oracle violated IBM copyright when it copied IBM's Structured Query Language to produce the first version of the Oracle database management system. (I doubt IBM gave Oracle explicit permission to use SQL back then)</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59633994">
<span class="ind"></span><a id="reply_link_59633994" class="btn link" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=Reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633994" onclick="D2.replyTo(59633994); return false;">Reply to This</a> 	<a href="#" class="comment_share_toggle btn link">Share</a>
	<div class="comment_share sharethis-0 hide"><span class="au"></span>
		<a class="janrain t" href="#" data-provider="twitter" data-message="Use Oracle's own arguments against them? by jonwil @slashdot" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633994" data-title="Use Oracle's own arguments against them?">twitter</a>
		<a class="janrain f" href="#" data-provider="facebook" data-message="Use Oracle's own arguments against them? by jonwil" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633994" data-title="Use Oracle's own arguments against them?">facebook</a>
		<a class="janrain l" href="#" data-provider="linkedin" data-message="Use Oracle's own arguments against them? by jonwil" data-url="https://linux.slashdot.org/comments.pl?sid=15607490&cid=59633994" data-title="Use Oracle's own arguments against them?">linkedin</a>
		<a class="g" href="https://plus.google.com/share?url=https://linux.slashdot.org/comments.pl?sid=15607490%26cid=59633994" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=600,width=600');return false;"><img src="//www.gstatic.com/images/icons/gplus-16.png" alt="Share on Google+"/></a>
	</div>
 <span class="ind"></span><a id="reply_link_59633994" title="Flag this comment as Inappropriate" class="ui-icon flag fright" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=flag&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=59633994" onclick="return false;">Flag as Inappropriate</a>
</div>
</div>

<div id="replyto_59633994"></div>

<ul id="group_59633994">
	<li id="hiddens_59633994" class="hide"></li>
</ul>

</li><li id="tree_59634232" class="comment oneline"><span class="ind"></span>
<div id="comment_status_59634232" class="commentstatus"></div>
<div id="comment_59634232" class="cw">
	<div id="comment_top_59634232" class="commentTop newcomment">
		<div class="title">
			<h4><a id="comment_link_59634232" name="comment_link_59634232" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;cid=59634232" onclick="return D2.setFocusComment(59634232)" >This one is really critical</a>


		 	<span id="comment_score_59634232" class="score"> (<a href="#" onclick="getModalPrefs('modcommentlog', 'Moderation Comment Log', 59634232); return false"><span class=opt>Score:</span>1</a>)</span></h4>
		</div>
		<div class="details">
			<span class="by"><span class="byby">by </span><a href="//slashdot.org/~rinka">rinka</a>  <span class="uid"><a href="//slashdot.org/~rinka">( 870438 )</a></span></a></span><span class="writes" style="display:none"> writes:</span> 
			<span class="otherdetails" id="comment_otherdetails_59634232"></span>
		</div>
	</div>
	<div class="commentBody">
		<div id="comment_body_59634232"><p>IMHO, it can have potentially far reaching implications if APIs are protected.  Applications use system APIs to run on top of Operating Systems.</p><p>It will be possible to lock specific applications and prevent them from running...</p><p>Oracle has traditionally never supported open systems.</p></div>
	</div>

	<div class="commentSub" id="comment_sub_59634232">

</div>
</div>

<div id="replyto_59634232"></div>

<ul id="group_59634232">
	<li id="hiddens_59634232" class="hide"></li>
</ul>

</li><li id="tree_59635358" class="comment hidden"><span class="ind"></span>
<div id="comment_status_59635358" class="commentstatus"></div>
<div id="comment_59635358" class="cw">
</div>

<div id="replyto_59635358"></div>

<ul id="group_59635358">
	<li id="hiddens_59635358" class="hide"></li>
</ul>

</li><li id="hidestring_0"><noscript><b class='more'><span class="ind"></span><a href="//linux.slashdot.org/comments.pl?sid=15607490&amp;threshold=-1&amp;commentsort=0&amp;mode=thread&amp;pid=0">1 reply</a> beneath your current threshold.</b></noscript></li>
			<li id="roothiddens" class="hide"></li>
		</ul>
	
	
	
	

<noscript><p><b>There may be more comments in this discussion. Without JavaScript enabled, you might want to <a href="//linux.slashdot.org/users.pl?op=editcomm">turn on Classic Discussion System</a> in your preferences instead.</b></p></noscript>
<div id="discussion_buttons" class="clearfix">






</div>


<div class="newcmnt"><div id="replyto_0"></div></div>


	<script type="text/javascript">
<!--
		D2.currents()['hidden']   = 7;
		D2.currents()['full']     = 10;
		D2.currents()['oneline']  = 24;
		// D2.currents_total(41);

		D2.abbrev_comments({59634376:515,59633980:512,59634074:529,59633910:536,59633956:515,59633938:512,59634092:522});
		D2.noshow_comments([59633970,59634192,59633982,59634008,59633952,59633986,59635358]);
		D2.pieces_comments([59633980,59634252,59634074,59635060,59634498,59633910,59633926,59633922,59633962,59633972,59634168,59634018,59633932,59633938,59633956,59634092,59635088,59634432,59634970,59634014,59634264,59634376,59634450,59634232]);
		D2.init_hiddens([59633904,59633926,59633916,59633932,59633940,0]);

		D2.finishLoading();


		if (D2.thresh_totals()[6][6][1] == 0) {
			D2.replyTo(0, 1);
		}


//-->
	</script>


</div>



	
	
		<div id="clickgen" class="grid_24 b">
    <section class="grid_16 f">
        <div>
			<h4 class="nobg">
			    <a href="" class="selected btmrel" onClick="getRelatedStoriesForStory(366050);return false">Related Links</a>
			    <span class="tops fright">Top of the: <a href="" class="btmday" onClick="getTopStories(1);return false">day</a>, <a class="btmweek" href="" onClick="getTopStories(7); return false">week</a>, <a href="" onClick="getTopStories(30);return false" class="btmmonth">month</a>.</span>
			</h4>
			<ul class="nobullets bmrelatedlist">


	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>966<span class="hide"> comments</span></span></span><a href="//linux.slashdot.org/story/19/04/07/2111218/why-arent-people-abandoning-windows-for-linux?sdsrc=popbyskidbtmprev">Why Aren't People Abandoning Windows For Linux?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>584<span class="hide"> comments</span></span></span><a href="//linux.slashdot.org/story/19/05/15/1523252/why-linux-on-desktop-failed-a-discussion-with-mark-shuttleworth?sdsrc=popbyskidbtmprev">Why Linux On Desktop 'Failed': A Discussion With Mark Shuttleworth</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>569<span class="hide"> comments</span></span></span><a href="//linux.slashdot.org/story/19/08/06/1839206/linux-performs-poorly-in-low-ram--memory-pressure-situations-on-the-desktop?sdsrc=popbyskidbtmprev">Linux Performs Poorly In Low RAM / Memory Pressure Situations On The Desktop</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>467<span class="hide"> comments</span></span></span><a href="//linux.slashdot.org/story/19/04/13/0151256/is-the-linux-desktop-in-trouble?sdsrc=popbyskidbtmprev">Is The Linux Desktop In Trouble?</a>
	</li>

	
	<li>
		<span class="cmntcnt"><span class="slant"></span><span>406<span class="hide"> comments</span></span></span><a href="//linux.slashdot.org/story/19/05/13/0336224/is-it-finally-the-year-of-linux-on-the-desktop-?sdsrc=popbyskidbtmprev">Is It Finally the Year of 'Linux on the Desktop' ?</a>
	</li>


</ul>
        </div>
    </section>
    <aside class="grid_8 st">
		<section class="grid_24 f">
			<div>
				<h5 class="tlnav"><a href="//news.slashdot.org/story/20/01/18/1753246/another-project-goes-private-amara-stops-being-developed-as-open-source?sdsrc=nextbtmnext">next</a></h5>
				<div class="grid_24">
	    
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/opensource_64.png" width="64" height="64" alt="Open Source"></span>
	    
					<p class="grid_12"><a href="//news.slashdot.org/story/20/01/18/1753246/another-project-goes-private-amara-stops-being-developed-as-open-source?sdsrc=nextbtmprev">Another Project Goes Private: Amara Stops Being Developed As Open Source</a></p>
					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>58<span class="hide"> comments</span></span></span></span>
	
				</div>
			</div>
		</section>
		<section class="grid_24">
			<div>
				<h5 class="tlnav"><a href="//developers.slashdot.org/story/20/01/18/0123210/slate-announces-list-of-the-30-most-evil-tech-companies?sdsrc=prevbtmprev">previous</a></h5>
				<div class="grid_24">
	    
            	 <span class="grid_7 tcenter"><img src="//a.fsdn.com/sd/topics/stats_64.png" width="64" height="64" alt="Stats"></span>
	    
					<p class="grid_12"><a href="//developers.slashdot.org/story/20/01/18/0123210/slate-announces-list-of-the-30-most-evil-tech-companies?sdsrc=prevbtmprev">Slate Announces List of The 30 Most Evil Tech Companies</a></p>

					<span class="grid_5 tcenter comments"><span class="cmntcnt_large fleft"><span class="slant"></span><span>148<span class="hide"> comments</span></span></span></span>
				</div>
			</div>
		</section>
	</aside>
</div>
		<div id="taboola-below-article-text-links"></div>
<script type="text/javascript">
	window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'text-links-a',
		container: 'taboola-below-article-text-links',
		placement: 'Below Article Text Links',
		target_type: 'mix'
});
</script>
	

</section>
			</div>
		</div>
		<div class="row top-space">


			<div class="grid_24">
				<!-- 728px ad -->

				<div class="adwrap">
<div id='div-gpt-ad-728x90_c'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-728x90_c');});</script></div>
</div>
				<!-- end 728px ad -->
				<!-- Slashdot Deals 6 Best Sellers -->
					<div class="row deals-footer">
						<div class="units-8 indent-2 deals-wrapper">
						  <div class="deals-header"><h1>Slashdot Top Deals</h1></div>
						  <div id="deals-output">
							<script id="deals-template" type="text/x-handlebars-template">
							  {{#each deal}}
								<div class="deal">
								  <a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">
								  	<img src="{{main_image}}" alt="" />
								  </a>
								  <p class="title"><a href="{{urlPath permalink}}?&utm_source=slashdot.org&utm_medium=dealfeed-footerfeed&utm_campaign={{slug}}" target="_blank">{{title}}</a></p>
								  <p class="deal-price">{{centConversion price_in_cents}}</p>
								</div>
							  {{/each}}
							</script>
						  </div>
						</div>
					</div>
					<script>
						if ( isAdBlockActive ) {
							$.getScript( "//a.fsdn.com/sd/js/scripts/min/deals-min.js", function(){
								runDealsWidget();
							});
						}
					</script>

					<!-- End Slashdot Deals 6 Best Sellers -->
				</div>
			</div>
		</div>
	</div>
	<!-- SMACKS: END COMMENTS SECTION -->
</div>
<!-- SMACKS: END COMMENTS CONTAINER -->


	

<script type="text/javascript">

$(function(){
$('#firehose-filter').
	focus(function(event){
		gFocusedText = this;
	}).
	blur(function(event){
		if ( gFocusedText === this ) {
			gFocusedText = null;
		}
	});


apply_updates_when(		'at-end', true);
});
</script>


<!-- body end --><!-- footer type=current begin -->
	
	</section>
	
	


	<footer id="fhft" class="grid_24 nf aoc">
		<div id="logo_nf" class="fleft">
			<a href="//slashdot.org"><span>Slashdot</span></a>
		</div>
		<nav role="firehose footer">
			
				
				
				
				

				
						<span class="ind"></span><a class="btn first" href="//linux.slashdot.org/comments.pl?sid=15607490&amp;op=reply&amp;threshold=1&amp;commentsort=0&amp;mode=thread&amp;pid=" onclick="D2.replyTo(0); return false;">Post</a>
				
				<a class="btn hide" id="footer_moderate_button">Moderate</a>
				<a class="btn hide" id="footer_moderatorhelp_button">Moderator Help</a>
				<a class="btn hide" id="footer_delete_button" title="Checked comments will be deleted.">Delete</a>
				<script>
					(function($){
						var old_moderate_btn = $("#discussion_moderate_button");
						if (old_moderate_btn.length) {
							var moderate_btn = $("#footer_moderate_button");
							moderate_btn.click(
								function(){old_moderate_btn.click()}
							);
							moderate_btn.removeClass('hide');
						}

						var old_moderatorhelp_btn = $("#discussion_moderatorhelp_button");
						if (old_moderatorhelp_btn.length) {
							var moderatorhelp_btn = $("#footer_moderatorhelp_button");
							moderatorhelp_btn.click(
								function(){old_moderatorhelp_btn.click()}
							);
							moderatorhelp_btn.attr(
								'href', old_moderatorhelp_btn.attr('href')
							);
							moderatorhelp_btn.removeClass('hide');
						}

						var old_delete_btn = $("#discussion_delete_button");
						if (old_delete_btn.length) {
							var delete_btn = $("#footer_delete_button");
							delete_btn.click(
								function(){old_delete_btn.click()}
							);
							delete_btn.removeClass('hide');
						}

						$('#discussion_buttons').addClass('hide');
					})(Slash.jQuery); // (function($){
				</script>
				<ul class="fleft">
					
						<li class="fleft selected">
							<span class="nbutton btn hide link reset" id="more_comments_button">
								<a href="#" onclick="D2.ajaxFetchComments(0,1); return false">
									<span id="more_comments_num_a" class="hide">Get more comments</span>
								</a>
							</span>
						</li>
					
					
						<li class="fleft">
							<span class="loadedcommentcnt">41</span> of <span class="totalcommentcnt">41</span> loaded
						</li>
					
				</ul>
				
					<script type="text/javascript">D2.finishLoading()</script>
				
			

			
			<ul class="fright submitstory">
					<li class="fright">
						<a href="/submit">Submit<span class="opt"> Story</span></a>
					</li>
			</ul>
		</nav>
		


	</footer>
	<section class="bq">
		<blockquote class="msg grid_24" cite="https://slashdot.org">
			<p>Great spirits have always encountered violent opposition from mediocre minds.
		-- Albert Einstein</p>
			<span class="slant"></span>
		</blockquote>
	</section>
	<footer id="ft" class="grid_24">
		<nav class="grid_10" role="footer">
			<ul>
				<li><a href="//slashdot.org/faq">FAQ</a></li>
				<li><a href="//slashdot.org/archive.pl">Story Archive</a></li>
				<li><a href="//slashdot.org/hof.shtml">Hall of Fame</a></li>
				<li><a href="http://slashdotmedia.com/advertising-and-marketing-services/" rel="nofollow">Advertising</a></li>
				<li><a href="http://slashdotmedia.com/terms-of-use/" rel="nofollow">Terms</a></li>
				<li><a href="http://slashdotmedia.com/privacy-statement/" rel="nofollow">Privacy Statement</a></li>
				<li id='eu_privacy' style='display:none'><a href="#" title="Privacy Choices" onclick="bizx.cmp.promptConsent();return false;">Privacy Choices</a></li>
				<li><a href="http://slashdotmedia.com/opt-out-choices/" rel="nofollow">Opt-out Choices</a></li>
				<li><a href="//slashdot.org/faq/slashmeta.shtml">About</a></li>
				<li><a href="mailto:feedback@slashdot.org">Feedback</a></li>
				<li><a href="#" onclick="set_mobile_pref('mobile',1);return false;">Mobile View</a></li>
				<li><a href="//slashdot.org/blog">Blog</a></li>
			</ul>
		</nav>
		<script>
		if (window.is_euro_union) {
			document.getElementById('eu_privacy').style.display = 'inline';
		}
		</script>
		<br>
		
		<div class="grid_14 tright tm">Trademarks property of their respective owners. Comments owned by the poster. <span class="nobr">Copyright &copy; 2020 SlashdotMedia. All Rights Reserved.</span></div>
	</footer>

	
	<div class="overlay"></div>
<div class="modal-box">
    <a href="#" id="close-modal">Close</a>
    <article class="modal-content">
    </article>
    <footer>
</div>




<div id="modal_cover" class="hide" onclick="hide_modal_box(); return false;"></div>
<div id="modal_box" class="hide">
      <div id="modal_box_content"></div>
      <header class="n">
                  <span class="fadeout"></span>
                  <span class="fadeoutfade"></span>
		  <span class="pf"><a class="ico close" onclick="hide_modal_box(); return false;" href="#"><span>Close</span></a></span>
		  <h3 class="pf"><div id="logo"><a href="//slashdot.org">Slashdot</a></div><span id="preference_title"></span></h3>
      </header>
</div>
	
	<!-- CCM Tag -->
<script type="text/javascript">
if (!window.is_euro_union) {
  (function () {
    /*global _ml:true, window */
    _ml = window._ml || {};
    _ml.eid = '771';

    var s = document.getElementsByTagName('script')[0], cd = new Date(), mltag = document.createElement('script');
    mltag.type = 'text/javascript'; mltag.async = true;
    mltag.src = '//ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth() + cd.getFullYear();
    s.parentNode.insertBefore(mltag, s);
  })();
}
</script>
<!-- End CCM Tag -->

<script type="text/javascript">
window.google_analytics_uacct = "UA-32013-5";

var _gaq = _gaq || [];





  _gaq.push(['_setAccount', 'UA-36136016-1']);
  _gaq.push(['b._setAccount', 'UA-32013-5']);
  _gaq.push(['_setDomainName', '.slashdot.org']);
  _gaq.push(['b._setDomainName', '.slashdot.org']);

	
		_gaq.push(['_addIgnoredRef', 'slashdot.org']);
		_gaq.push(['b._addIgnoredRef', 'slashdot.org']);
	


  _gaq.push(['_setCustomVar', 1, 'User Type',  'Anon', 3]);
  _gaq.push(['b._setCustomVar', 1, 'User Type',  'Anon', 3]);		
	
	_gaq.push(['_setCustomVar', 2, 'Page','article2', 3]);
	_gaq.push(['b._setCustomVar', 2, 'Page','article2', 3]);

	



// track beta behavior for user
var betamatches = document.cookie.match(/betagroup=(-?\d+)/);

if(betamatches && betamatches[1]) {
  if(betamatches[1] == -1) {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','opt-out', 3]);
  } else {
    _gaq.push(['_setCustomVar', 3, 'Beta-Usage','unredirected', 3]);
  }
}



  _gaq.push(['_trackPageview']);
  _gaq.push(['b._trackPageview']);
  _gaq.push(['_trackPageLoadTime']);
  _gaq.push(['b._trackPageLoadTime']);


if (!window.is_euro_union) {
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
}
</script>

<!-- CCM GA Push -->
<script>
    if (typeof _ml !== 'undefined' && _ml.us) {
        if (_ml.us.tp && _ml.us.tp.length > 0) {
            ga('set', 'dimension2', _ml.us.tp[0]);
        }
        if (_ml.us.pc && _ml.us.pc.length > 0) {
            ga('set', 'dimension7', _ml.us.pc[0]);
        }
        ga('set', 'dimension3', _ml.us.ind);
        ga('set', 'dimension4', _ml.us.cr);
        ga('set', 'dimension5', _ml.us.cs);
        ga('set', 'dimension6', _ml.us.dm);
        ga('set', 'dimension8', _ml.us.sn);
    }
</script>

<!-- Sticky Ads -->
<script type="text/javascript">
var topBannerViewed = false;
if($('#div-gpt-ad-728x90_a').length > 0 && $('#div-gpt-ad-300x250_a').length > 0 && window.outerWidth >= 1070 && !isAdBlockActive){
    $(window).scroll(function(){
        var y = $(document).scrollTop();
        var z =  y + window.outerHeight;
        var navOffset = 0;
        var offset = [
            $('.nav-wrap').outerHeight(true),
            $('.nav-secondary-wrap').outerHeight(true)
        ];
        for(row in offset){
            if(offset[row]) navOffset = navOffset + parseInt(offset[row]);
        }
        $('.adwrap-unviewed').each(function(){
            var cls = 'adwrap-sticky';
            var toggleCls = 'adwrap';
			//$('.banner-wrapper').css('height', $('.banner-contain').outerHeight());
            if($(this).hasClass('railad')) {
                if(topBannerViewed){
                    var topPixels = $(this).offset().top;
                    navOffset += $('.adwrap').outerHeight();
                    if(y >= topPixels && y >= navOffset){
                        $('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
                    } else {
                        $('#slashboxes').removeAttr('style');
                    }
                }
                return;
            }
            var topPixels = $(this).offset().top;
        if(y >= topPixels && y >= navOffset){
                $(this).addClass(cls);
                $(this).removeClass('adwrap');
				if(cls == 'adwrap-sticky') { //top banner
                    topBannerViewed = false;
					$('#slashboxes').css('top',$(this).outerHeight() || 0).css('position','fixed').css('right',13);
				}
        if(topBannerViewed) {
                    //console.log('hereeee');
					$('#slashboxes').css('top', 0).css('position','fixed').css('right',13);
				}
            }else{
								//console.log('topBannerViewed', topBannerViewed);
                $(this).removeClass(cls);
                $(this).addClass(toggleCls);
                $('#slashboxes').removeAttr('style');
            }
        });
		if($('.adwrap-viewed-banner').length > 0){
		  //console.log('ads topBanner displayed');
			topBannerViewed = true;
			$('.adwrap-viewed-banner').removeClass('adwrap-unviewed').removeClass('adwrap-sticky').addClass('adwrap');
		}
    if($('.adwrap-viewed-railad').length > 0){
						//console.log('ads sidebar displayed');
            $('.adwrap-viewed-railad').removeClass('adwrap-unviewed').removeClass('adwrap-railad-sticky');
			$('#slashboxes').removeAttr('style');
		}
    });
}
</script>

<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(["setCookieDomain", "*.slashdot.org"]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
function initPiwikAndNels() {
  (function() {
    var u="//analytics.slashdotmedia.com/";
    _paq.push(['setTrackerUrl', u+'sd.php']);
    _paq.push(['setSiteId', 40]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'sd.js'; s.parentNode.insertBefore(g,s);
  })();

    if(window.location.pathname == '/'){
        var nelId = (location.search.split('nel_id=')[1] || '').split('&')[0];
        var url = '/ajax.pl?op=nel';
        if(nelId){
            url += '&nel_id='+nelId;
        }
        $.ajax({
            url: url,
            success: function(html){
                $('#firehoselist article').eq(1).after(html);
            }
        });
    }
    //announcement NEL
    if(document.getElementById('announcementText')){
      $('#announcementText').hide();
      var hlUrl = '/ajax.pl?op=hl_nel';
      if(nelId){
        hlUrl += '&nel_id='+nelId;
      }
      $.ajax({
        url: hlUrl,
        success: function(html){
          if(html.length < 10){
            $('#announcementText').show();
            return;
          }
          $('#announcementText').html(html).show();
        },
        error: function () {
          $('#announcementText').show();
        }
      });
    }
}
bizx.cmp.ifConsent('publisher', ['storage', 'measurement'], initPiwikAndNels);
</script>


<script type="text/javascript">
_linkedin_data_partner_id = "113712";
</script><script type="text/javascript">
if (!window.is_euro_union) {
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
}
</script>
<noscript>
<img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=113712&fmt=gif" />
</noscript>

<!-- Datonics -->
<script async type="text/javascript" src="//ads.pro-market.net/ads/scripts/site-143573.js"></script>
	<script id="after-content" type="text/javascript">
(function( $, fn, console ){
	$ && fn && $(function(){ fn($, console); });
})(window.jQuery, window.pageload_done, window.console);
</script>
	
	<script type='text/javascript'>
	if(!document.location.href.match(/source=autorefresh/)) {
		document.write('<img src="//slashdot.org/images/js.gif?64">');
	}
</script>
<noscript>
	<img src="//slashdot.org/images/njs.gif?7">
</noscript>
	<div class="busy genericspinner hide"><span>Working...</span></div>
	<script>
		if(typeof(Storage)!=="undefined"){
			window.scrollTo(0,sessionStorage.scrollPos);
				$(window).scroll(function () {
				//You've scrolled this much:
				sessionStorage.scrollPos = $(window).scrollTop();
			});
		}
		$(function(){
			$('a').click(function(){
				delete sessionStorage.scrollPos;
			})
		});
		// window.onbeforeunload = function () {
		// 	console.log('bakc button clicked');
		// 	delete sessionStorage.scrollPos;
		// }
		window.onpopstate=function() {
			delete sessionStorage.scrollPos;
		}
	</script>
	

	
		<!-- 1x1 story page -->
		<div id='div-gpt-ad-1x1'><script type='text/javascript'>
googletag.cmd.push(function(){
googletag.display('div-gpt-ad-1x1');});</script></div>
	

	<script type="text/javascript">
	if (!window.is_euro_union) {
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
	}
	</script>

	</body>
	</html>


	<!-- footer type=current end -->