Follow Slashdot stories on Twitter

 



Forgot your password?
typodupeerror
Linux

Linux Kernel 4.14 Will Be An LTS Release (softpedia.com) 46

prisoninmate writes: Development of the Linux 4.14 kernel series did not even start, as the version that's being developed these days is Linux 4.12, which should be promoted to stable early next month, but Softpedia reports that renowned Linux kernel maintainer Greg Kroah-Hartman announced earlier this morning that the upcoming Linux 4.14 kernel series will be an LTS (Long Term Support) branch. The developer promises to support the Linux 4.14 kernel series for at least two years after its release in November 2017, probably until November 2019.
This discussion has been archived. No new comments can be posted.

Linux Kernel 4.14 Will Be An LTS Release

Comments Filter:
  • "Development of the Linux 4.14 kernel series did not even start" I can't even get past the first clause, much less the first sentence.
    • So please edumacate me: what's be bad with grammar in that clause?

      Parses clearly to me: (development of (the Linux 4.14 kernel series)) ((did not even) start).

      If you're after the verb phrase, "did not even", it's correct and widespread: 1 [ludwig.guru] 2. [usingenglish.com]

      • Re: Horrible grammar (Score:2, Informative)

        by Anonymous Coward

        "It did not even start" is past tense.

        "It hasn't even started yet" is better.

        • by Anonymous Coward

          "Development did not start" is past tense. This is incorrect, because we are talking about the current state of development, not a past moment.

          "Development did not even start" is past tense, and compounds its incorrectness, by implying that development SHOULD HAVE STARTED ALREADY. It is garbage English.

          "Development has not started", "Development has yet to start" - this is PRESENT TENSE, PERFECT ASPECT. This is CORRECT. The status of the development is being reported in the present.

      • Re:Horrible grammar (Score:4, Informative)

        by wonkey_monkey ( 2592601 ) on Sunday June 18, 2017 @01:34PM (#54642971) Homepage

        It should be "has not even started." The tense is wrong. It's a pretty bad sentence aside from that, too.

  • Bahaha! Did he require them to call him that or are they just kissing ass?

  • I used to always run the latest Linux kernel, but since I run VMWare, I ran into too many problems with broken modules doing that. While I would love to see them get all of their modules into the mainline kernel (I fail to see why they really need something that couldn't be a generic service), that's really not relevant to this discussion. I've also had some problems with Nvidia modules, though to a much lesser extent.

    So now my strategy it to always go with the latest LTS kernel. This has proven to be a

  • I hope the fuck that it is better than 4.4. Having a LTS kernel come out with updates every few days is a complete joke. You may argue often, release early, but these are kernels used by the distos which do no such thing. Those that want release often, are more than likely to be using bleeding edge kernels, not LTS. Opensuse is at the moment using 4.4.70, yet the latest is 4.4.73. If you want Linux to succeed on the desktop, then bringing out new kernels every few days is not the way to do it.
  • Why not just call it 4.2?
    For simplicity. Personally they should have gone with a year-month versioning system, so you can see how non-bleeding edge you are...

Memory fault -- core...uh...um...core... Oh dammit, I forget!

Working...